[Olsr-users] Olsr-users Digest, Vol 75, Issue 2

Shyam B (spam-protected)
Mon Sep 9 19:17:06 CEST 2013

Hi Brian/ Others,

Thank you for your help so far. I am closer to the problem, I believe.

To summarize, I am using 2 Raspberry PI's in simple 'Ad-hoc mode', channel
10, *same* ESSID on both nodes. Setup for one Raspberry PIs, is perfectly
identical to the other one (I have crosschecked all parameters).

Device: Edimax EW-7811Un (One of the recommended dongle's with RPi -
enables Ad-Hoc mode: Ch 01:11)
Device driver does NOT seem to be a problem here. I can see the gateway
router of OLSR with Rpi over wlan0 but *NOT* another Rpi with same
configuration over wlan0.

Ok, first lets* DISABLE OLSR,* just simple Ad-hoc mode on two RPi's and try
to PING each other over wlan0. I am *able* to do this with RPi and a
TP-Link OpenWRT based router in Ad-hoc mode *with OR without OLSR*.

E.g. setup:

(spam-protected) ~ $ cat /etc/network/interfaces
auto lo
iface lo inet loopback
iface eth0 inet dhcp
auto wlan0
iface wlan0 inet static
    wireless-channel 10
    wireless-essid irt-ah-inria
    wireless-mode ad-hoc

(spam-protected) ~ $ iwconfig wlan0
wlan0     IEEE 802.11bg  ESSID:"irt-ah-inria"  Nickname:"<(spam-protected)>"
          Mode:Ad-Hoc  Frequency: 2.457 GHz Cell: 0E:75:4D:3C:D9:3A   Bit
Rate:54 Mb/s
      Tx-Power=20 dBm
      Retry long limit: 7 RTS thr:off Fragment thr:off
          Power Management:on

(spam-protected) ~ $ sudo iwlist wlan0 scan
wlan0     Scan completed :
          Cell 01 - Address: 02:11:87:FA:4A:02
                    Protocol:IEEE 802.11bg
                    Frequency:2.457 GHz (Channel 10)
                    Encryption key:off
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s

*Ip is* and *broadcast IP *is over all subnets: **

Everything is fine uptil this point. For the question raised earlier, here
is my observation.

(1) I am ABLE to ping between the two RPi via eth0 but not via wlan0 (seems
like a layer two issue - hard to believe)! I have multiple RPis and
dongles, tested with others - same issue!
(2) I am able to run OLSR on the eth0 interface - yes, this works. RPi can
see each other.
(3) I am NOT able to see the other RPi over wlan0. IF I am able to 'ping'
the two RPi's in simple Ad-Hoc mode (no rocket science), I am sure OLSR
must work then (as with eth0)..
(4) I ran 'arp-scan' to scan the device address over wlan0. This is not
able to identify the hw-MAC address of the other RPi wlan0 device.

I am certainly missing something really tiny. This must work! Have spent
countless hours figuring what's wrong. Maybe someone's expertise can help
me or maybe can do a similar setup.

Thanks in advance,

On Mon, Sep 9, 2013 at 4:51 AM, Brian D Heaton <(spam-protected)> wrote:

>  Shyam,
> Do you have the same SSID configured on both nodes?  You indicate that
> they are both on the same channel, both set to ad-hoc mode, and both
> wireless interfaces are in the same subnet.  If all those conditions are
> true, and the SSIDs match, you don't need the routing protocol to ping
> between the nodes.
> Just to be sure - you're attempting to ping the other node's wireless
> interface directly from the Rpi - NOT from a PC connected to the Rpi's
> Ethernet port.  Have you tried setting the source interface of the ping to
> the wireless interface? "ping a.b.c.d -I wlan0" (or whatever your wireless
> interface is called).
> -Brian
> On 9/8/2013 10:14 AM, Shyam B wrote:
>    Hi Henning,
>  Thank you for your response.
>  I am trying to let each RPi see the other in the network and communicate
> with each other.
> The situation right now is that both Raspberry PI's have similar
> connectivity, having:
>  ESSID, Channel 11 (2.457GHz), Ad-Hoc mode.
>  Each configured to a static IP in the same subnet.
>  I can see the other node via *iwlist scan* (that is I can sense the
> other node in the network, I have tested with different ESSID's to verify).
>  To your question, I am unable to ping from one node to the other. (Note
> I  DO NOT have a gateway configured). This is what I am confused on, as to
> if I should be able to.
> It can communicate with a TP-Link router (which is configured as a router
> by default), and packets can go through them.
>  My question is:
>  1) Is a gateway required for OLSR to route packets?
> 2) Right now, i have two (and later several) isolated nodes in the
> network. No gateways. Can I not be able to communicate? If not, why not?
>  3) I have attached the olsr.conf file for the Rpi in the earlier mail.
>  Any details will certainly help me understand where I am going wrong.
> Thanks in advance,
> Shyam
>> ----------------------------------------------------------------------
>> Message: 1
>> Date: Thu, 5 Sep 2013 13:42:46 +0200
>> From: Henning Rogge <(spam-protected)>
>> To: <(spam-protected)>
>> Subject: Re: [Olsr-users] Fwd: Configuring two nodes directly (without
>>         a gateway) - OLSR.
>> Message-ID: <(spam-protected)>
>> Content-Type: text/plain; charset="iso-8859-1"; Format="flowed"
>> Hi,
>> do you have already checked that you have direct IP connectivity? Can
>> you ping the other node over the network?
>> If you only have two nodes, ping will work with or without OLSR, because
>> you can only communicate with 1-hop neighbors without routing protocol.
>> If you cannot ping the other node, then you have trouble on layer-2
>> (wifi) or with your interface configuration.
>> Henning Rogge
>> On 09/05/2013 01:36 PM, Shyam B wrote:
>> > Hi Al,
>> >
>> > I am configuring _multiple RaspberryPI's_ as nodes in a mesh network. I
>> > don't plan to use routers as gateway. Having installed OLSR on these
>> > nodes (currently two to begin with), I am unable to communicate between
>> > them.
>> > The configuration was working with the routers.
>> >
>> > _What I did_
>> >
>> > Exactly same setup on the two nodes:
>> > Ad-Hoc mode, Channel 10 with same ESSID.
>> > Tried to change hna, Ip4Broadcast to the same subnetwork as well.
>> > Nothing works!
>> >
>> > The iwconfig screenshot and olsrd.conf file attached. I have spent
>> > multiple hours trying to get it to work!!
>> >
>> > It would be of real help if someone can point out if communication
>> > between two raw nodes is selected. If not why not, and what do I have to
>> > do to make this setup work. Eagerly looking forward!
>> Henning Rogge
>> --
>> Diplom-Informatiker Henning Rogge , Fraunhofer-Institut f?r
>> Kommunikation, Informationsverarbeitung und Ergonomie FKIE
>> Kommunikationssysteme (KOM)
>> Fraunhofer Stra?e 20, 53343 Wachtberg, Germany
>> Telefon +49 228 9435-961,   Fax +49 228 9435 685
>> mailto:(spam-protected) http://www.fkie.fraunhofer.de
>> -------------- next part --------------
>> A non-text attachment was scrubbed...
>> Name: smime.p7s
>> Type: application/pkcs7-signature
>> Size: 6169 bytes
>> Desc: S/MIME Cryptographic Signature
>> URL: <
>> http://lists.olsr.org/pipermail/olsr-users/attachments/20130905/8719cf55/attachment-0001.bin
>> >
>> ------------------------------
>> --
>> Olsr-users mailing list
>> (spam-protected)
>> https://lists.olsr.org/mailman/listinfo/olsr-users
>> End of Olsr-users Digest, Vol 75, Issue 2
>> *****************************************
> --
> Best Regards,
> Shyam

Best Regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.olsr.org/pipermail/olsr-users/attachments/20130909/d1ff3d57/attachment.html>

More information about the Olsr-users mailing list