[Olsr-users] Finding OLSR v0.6.3-3 node with empty node table?

Ben West (spam-protected)
Sat Oct 6 15:00:44 CEST 2012

Hi Markus,

My apologies for being too generic.  logread on the effected node
unfortunately didn't reveal anything outside normal log messages (at least
within the ring buffer remaining).  Since the original problem manifested
itself after the node rebooted itself (per cronjob), I tried another
reboot, but the problem was not repeated.

I am attaching the /etc/config/olsr below.

The command 'echo "/all" | nc localhost 2006' reported all empty tables,
although I didn't happen to check "/interfaces" before restarting olsrd.  I
will be mindful to do that should this situation recur.

Contents of /etc/config/olsrd:

config 'olsrd'
  option 'IpVersion' '4'
  option 'LinkQualityLevel' '2'
  option 'LinkQualityAlgorithm' 'etx_ffeth'
  option 'SmartGateway' 'yes'
  option 'Pollrate' '0.2'
  option 'UseHysteresis' 'no'
  option 'NatThreshold' '0.5'

config 'LoadPlugin'
  option 'library' 'olsrd_arprefresh.so.0.1'

config 'LoadPlugin'
  option 'library' 'olsrd_dyn_gw.so.0.5'

config 'LoadPlugin'
  option 'library' 'olsrd_secure.so.0.6'
  option 'Keyfile' '/etc/olsrd.d/olsrd_secure_key'

config 'LoadPlugin'
  option 'library' 'olsrd_httpinfo.so.0.1'
  option 'port' '1978'
  list 'Net' ''

config 'LoadPlugin'
  option 'library' 'olsrd_nameservice.so.0.3'
  #option 'resolv_file' '/tmp/resolv.conf.auto'
  option 'sighup_pid_file' '/var/run/dnsmasq.pid'
  option 'suffix' '.mesh'

config 'LoadPlugin'
  option 'library' 'olsrd_p2pd.so.0.1.0'
  option 'P2pdTtl' '5'

config 'LoadPlugin'
  option 'library' 'olsrd_txtinfo.so.0.1'
  option 'accept' ''

config 'Interface'
  list 'interface' 'mesh'
  option 'Mode' 'mesh'
  option 'Ip4Broadcast' ''

On Sat, Oct 6, 2012 at 2:24 PM, Markus Kittenberger <
(spam-protected)> wrote:

> On Sat, Oct 6, 2012 at 1:23 PM, Ben West <(spam-protected)> wrote:
>> For the past week, I've been playing around with olsrd v0.6.3-3 compiled
>> from OpenWRT trunk r33537 on a mesh of four UBNT M5 devices.  Just now, I
>> discovered a Bullet M5 which had (from external monitoring) apparently lost
>> its default route after an automated reboot.
>> Upon inspection locally, querying olsrd @ port 2006 returned an entirely
>> empty node table, despite iw wlan0 station dump reporting very good RSSI
>> with the gateway node.  Restarting olsrd on that node let the node table be
>> appropriately (re)populated, and restored its route.
>> Has this behavior been observed by others?
> I would say not very often,.. but your descriptino is very generic,..
> But there is the watchdog plugin, to help somehow
> (infact just against olsrd main-loop hangs, which if txtinfo still worked,
> you afaict did not suffer from)
> But did you look for anything on the syslog?
> Or did e.g. txinfo (port 2006) /interfaces reported any active olsrd
> interfaces?
> Which could give some hints, what olsrd's problem actually was about.
> Markus
>> --
>> Ben West
>> (spam-protected)
>> --
>> Olsr-users mailing list
>> (spam-protected)
>> https://lists.olsr.org/mailman/listinfo/olsr-users
> --
> Olsr-users mailing list
> (spam-protected)
> https://lists.olsr.org/mailman/listinfo/olsr-users

Ben West
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.olsr.org/pipermail/olsr-users/attachments/20121006/25c06c7b/attachment.html>

More information about the Olsr-users mailing list