[Olsr-users] Kamikaze 8.09_rc1 olsrd: can't resolve symbol '__libc_pthread_init'

Derek C (spam-protected)
Sun Nov 9 20:06:50 CET 2008

Hi all,

I've been experimenting with a Ubiquite Lite Station 2 (Atheros 2316 based).

I've tried to be lazy:  I'm using Ubiquity's own kamikaze 8.09 bin for
their LS2 and then I separately compiled up my own kamikaze 9.09 Atheros
231X image and, with my image, I included OLSRD along with other
requirements I have like DHCPd, Microperl, Chilli spot, etc).

I found that I was able to ssh in my dhcpd over to the LS2 and it worked. 
But when I tried to ssh over oslrd I found I was missing libpthread.so.0. 
No problem I thought and I copied over libpthread-0.9.29.so and symlinked
it to libpthread.so.0 (just like in the image I compiled).

Now when I execute olsrd I get this error: "olsrd: can't resolve symbol

Does anyone know if I can get away with what I'm tring to do?

thanks very much,


Derek C
In Ireland

More information about the Olsr-users mailing list