[Olsr-users] Kamikaze 8.09_rc1 olsrd: can't resolve symbol '__libc_pthread_init'

L. Aaron Kaplan (spam-protected)
Sun Nov 9 20:22:52 CET 2008

if my memory serves me right, then libpthread should be only used for  
one of the plugins in olsrd.
(please: fellow coders - correkt me if I am wrong, was it txtinfo?  
So you could - as a first measure - try do disable all plugins.

Second - I would try to build libpthread in the same build  
environment which was used to compile the original
cross compilation toolchain that you used. In openwrt this is simple:  
just add pthread to make menuconfig (or enable it in the .config  
file) and rebuild.


On Nov 9, 2008, at 8:06 PM, Derek C wrote:

> Hi all,
> I've been experimenting with a Ubiquite Lite Station 2 (Atheros  
> 2316 based).
> I've tried to be lazy:  I'm using Ubiquity's own kamikaze 8.09 bin for
> their LS2 and then I separately compiled up my own kamikaze 9.09  
> Atheros
> 231X image and, with my image, I included OLSRD along with other
> requirements I have like DHCPd, Microperl, Chilli spot, etc).
> I found that I was able to ssh in my dhcpd over to the LS2 and it  
> worked.
> But when I tried to ssh over oslrd I found I was missing  
> libpthread.so.0.
> No problem I thought and I copied over libpthread-0.9.29.so and  
> symlinked
> it to libpthread.so.0 (just like in the image I compiled).
> Now when I execute olsrd I get this error: "olsrd: can't resolve  
> symbol
> '__libc_pthread_init'"
> Does anyone know if I can get away with what I'm tring to do?
> thanks very much,
> Derek
> -- 
> --
> Derek C
> In Ireland
> -- 
> Olsr-users mailing list
> (spam-protected)
> http://lists.olsr.org/mailman/listinfo/olsr-users

More information about the Olsr-users mailing list