[OLSR-users] Windows: does not route/nat

Andreas T√łnnesen (spam-protected)
Tue Feb 15 09:36:23 CET 2005


> I thought I don't have to enable routing or something else in windows
> manually. Sounds like I misunderstood something ;-)

Well - both yes and no. Olsrd makes sure internal routing in the OLSR
network works(including enabling IP forwarding in the OS). But as soon as
a node decides to announce itself as a GW to an external network, olsr
will only set up a route to that node and do nothing more. Ofcause in a
perfect IPv6'ish world, everybody would have a global address assigned and
there would be no need for things like NAT :)
One could create a installer/setup application that enabled NAT(if
desired) and ran olsrd with HNA announcement, but this is beyond the scope
of olsrd itself IMO.

- Andreas


>
>
>
>
>
> ---------------------------------------------------------------------------
> Hi Dianiel,
>
> I might missunderstand your question, but to me it sounds like olsrd is
> doing just what
> it is supposed to :-) The gateways set up in a OLSR routed network must
> be able to
> act like gateways and OLSR is in no way responsible for setting up
> things like NAT on
> gateways. OLSR adds default routes via nodes announcing Internet
> connectivity,
> this is based on the assumption that theese nodes actually can route
> traffic to and from
> Internet. Setting up a NAT enabled gateway is something you must do
> manually in your
> case.
>
> If you have set PC1 up as a NAT router, then there is probably a
> configuration problem
> of some sort. Please report back if this is the case.
>
> - Andreas
>
> (spam-protected) wrote:
>
>>I installed the olsr 0.8.1-package with installer.
>>
>>Settings (PC1):
>>
>>LAN:
>>IP: 172.16.154.101
>>Sub: 255.255.255.0
>>Gateway: 172.16.154.253
>>DNS1: 172.16.90.251
>>DNS2: 172.16.90.252
>>
>>WLAN:
>>IP: 192.168.1.1
>>Sub: 255.255.255.0
>>
>>OLSR with standard-settings, Internet-sharing enable, only wlan interface
>>checkbox ticked
>>
>>Settings (PC2):
>>WLAN:
>>IP: 192.168.1.2
>>Sub: 255.255.255.0
>>
>>When I start OLSR, it correctly sets 192.168.1.1 as gateway
>>
>>>From PC2 i can ping PC1 (over WLAN), but I cannot access the internet. I
>>think PC1 does not route.
>>
>>
>>What should I do?
>>
>>
>>
>>greetz Daniel
>>
>>
>>
>>
>>
>
> _______________________________________________
> olsr-users mailing list
> (spam-protected)
> https://www.olsr.org/mailman/listinfo/olsr-users
>
> --
> Lassen Sie Ihren Gedanken freien Lauf... z.B. per FreeSMS
> GMX bietet bis zu 100 FreeSMS/Monat: http://www.gmx.net/de/go/mail
> _______________________________________________
> olsr-users mailing list
> (spam-protected)
> https://www.olsr.org/mailman/listinfo/olsr-users
>


---------
Andreas T√łnnesen
http://www.olsr.org



More information about the Olsr-users mailing list