[OLSR-users] Problem about powerstatus plug-in in olsrd-0.4.9(Urgent)

ken chung (spam-protected)
Thu Apr 7 18:28:01 CEST 2005

I run olsrd-0.4.9 between desktop and notebook using APM power( both are
Linux mechine).

When I run powerstatus plug-in, I use AC power in notebook first and
then observe the power data in desktop. Then I use battery in notebook
and observe the power data in desktop again. The incorrect power data is
shown in desktop, because my notebook still has 70% power. 

Desktop's power table:

[]: AC
[]: AC
[]: BATTERY P: 0% T: 0 mins <---
[]: BATTERY P: 0% T: 0 mins <---

Moreover, is the newest vesrion supoort ACPI. Even my notebook using
ACPI power, the problem is same as above

Besides, when I run olsd at the begining, the error is shown below:

---------- Plugin loader ----------
Library: olsrd_power.so.0.3
OLSRD Powerstatus plugin 0.3 by Andreas T?nnesen
Checking plugin interface version.... 2 - OK
Trying to fetch register function....OK
Trying to fetch plugin IO function....OK
Trying to fetch param function....FAILED: "olsrd: undefined symbol: <---
Running registration function...
Node has APM info!
---------- LIBRARY LOADED ----------

Can anyone help me to fix it?
It is because I need to show this plug-in in my final year project
Thank you very much

More information about the Olsr-users mailing list