[OLSR-users] some problem about olsrd-0.4.9

Andreas Tønnesen (spam-protected)
Tue Apr 5 07:42:25 CEST 2005

Hi John,

I have not had anything to do with the dyn_gw plugin lately so I really
don't know much about the code. The plugin uses the pthread library, so
if there is a problem with this lib then the plugin will naturaly fail.
Has anybody else sucessfully used current dyn_gw on the wrt?
0.4.9 is based directly off current CVS(olsrd-0-4-9 tag) with no real
code changes. If you can make your binary image available somewhere I
can give it a shot on my WRT.

- Andreas

John Gorkos wrote:
> Andreas-
>   There's definitely something awry.  dyn_gw works fine on original WRT54G 
> builds, but the newer build it will not run.  I removed the -lpthread from 
> the Makefile and sent it out, and I get the same segfault as soon as it tries 
> to load the plugin.
>   I don't have a router anywhere near me to test on:  I'm in new orleans, and 
> all of the routers are in Kansas.  I drove 14 hours to get here, so I'm a 
> little loathe to drive back right away...  Unfortunately, I don't have gdb 
> loaded on any of the routers, either, and since they're in production, I'd 
> rather not monkey too much with them.  I've discovered that if you make 
> massive changes to jffs, the router will not reboot (soft boot) properly, and 
> you have to hard (power cycle) boot it.  Since that involves a person 
> climbing into a 50 year old attic at an hourly rate, I try not to do it.
>   I can give you a copy of the binary firmware I'm running on the new routers, 
> if you'd like.  Perhaps you could load it onto one of yours and test with it.  
> Sorry to be a pain.  I only need dyn_gw on two routers, and both of them are 
> the old firmware, so it's not a showstopper for me.
>   BTW, the current ipkg file is based on the CVS from a few days ago.  I ran 
> another CVS update tonight and the only change in the tree was the release 
> notes.  If the current CVS is what you released, then I'm just going to leave 
> the .ipkg up on the ab0oo feed.  Let me know.
> John Gorkos
> On Monday 04 April 2005 15:11, Andreas Tønnesen wrote:
>>Hi Ken,
>>Thanks for your quick feedback on 0.4.9!
>>This could be a real showstopper... We could need your help in tracing
>>the problem. What kind of configuration do you use? Do you use any
>>Could you run olsrd in the GNU debugger? To start do:
>>gdb olsrd
>>Then if olsrd crashes you do:
>>and send back the information this outputs.
>>- Andreas
>>ken chung wrote:
>>>When I run olsrd-0.4.9(linux) in local machine, and other node is
>>>running olsrd-0.4.8(window) between 2 nodes, the error occur:
>>>       *** olsr.org - 0.4.9 (Apr  5 2005) ***
>>>--- 03:34:17.61 ----------------------------------------------------
>>>IP address       hyst   LQ     lost   total  NLQ    ETX
>>>         0.000  0.000  0      0      0.000  0.00
>>>--- 03:34:17.61 ------------------------------------------------
>>>IP address       LQ     NLQ    SYM   MPR   MPRS  will
>>>         0.000  0.000  YES   NO    NO    6
>>>--- 03:34:17.61 -------------------------------------------------
>>>Source IP addr   Dest IP addr     LQ     ILQ    ETX
>>>Segmentation fault
>>>[(spam-protected) olsrd-0.4.9]#
>>>Can you tell me how to fix it?
>>>olsr-users mailing list
> _______________________________________________
> olsr-users mailing list
> (spam-protected)
> https://www.olsr.org/mailman/listinfo/olsr-users

Andreas Tønnesen

More information about the Olsr-users mailing list