[Olsr-dev] Routing across multiple interfaces

Chiang Kang Tan (spam-protected)
Wed Jan 23 13:06:36 CET 2008

Hi Aaron,
Thanks for the quick reply! Save me from scratching my head off :) The problem I posted is no longer a problem! Thanks.

Please see comments inline as well



----- Original Message ----
> From: Aaron Kaplan <(spam-protected)>
> To: Chiang Kang Tan <(spam-protected)>
> Cc: (spam-protected)
> Sent: Wednesday, 23 January, 2008 10:57:29 AM
> Subject: Re: [Olsr-dev] Routing across multiple interfaces
> General remark:
> dropped routes due to fragmented TC messages were a bug in 0.5.4
> same with NLQ=0 (i.e. the ETX was considered 0)
> (this seems to have only happened in bigger networks)
I think the problem comes from the TC messages, which I wasn't aware
> please update to the most current version:
> http://olsrd.sourceforge.net/hg/olsrd/archive/tip.tar.gz
> And do report bugs in 0.5.5 please :)
will do :)
> a.
> On Jan 23, 2008, at 11:43 AM, Chiang Kang Tan wrote:
> > Hi all,
> >     I'm using olsrd-0.5.4 on a 802.11 network of 3 machines, one with
> >  two wireless interfaces (on different  wireless channel and subnet):
> >     [Node 1] <->[Node 2] <->
> >[Node 3]
> >     I was expecting olsrd to be able to handle multiple interfaces  
> > like
> what is the netmask? by the way, olsrd works with hoste routes.
> the nodes can all be from the same network and in the same netmaks.
> Even different interfaces are allowed to be in the same subnet
The netmask i use is The reason I'm using different
subnet for different interfaces was I didn't want to complicate olsr. But
I've just tried putting all interfaces on the same subnet (
and it works just fine too! That's really good.
> >  this, i.e. Node 1 is able to send to Node 3 via Node 2. In fact I am
> >  able to send from Node 1 to Node 3, but only for the first 5  
> > seconds or
> >  so after all the olsrd daemon on these nodes are started, roughly
> >  at the same time. When I check the routing table on Node 1 or
> Node
> >  each of them display a route to each other, via Node 2. But the  
> > route is
> >  then deleted from the routing table. I found out that the route  
> > entry is deleted due to mismatch in routing tree version.
> can you specify what you mean exactly by mismatch in in routing tree  
> version?
In olsr_delete_outdated_routes(), there is a section of code that deals
with checking for unequalness between routingtree_version and
rtp->rtp_version. Presumably the TC message did not arrive properly
from the MPR that causes the routingtree_version to progress faster
than that is kept? Often I'm shown debug messages that tell me that
all the kernel routes are deleted, and then subsequent kernel route
updates add the route entries back into the kernel routing table. There
the problem arises where the 2 hop route did not get added back to the
routing table. However the 2 hop neighbour (say in my case)
still keeps showing in the "two-hop neighbour" table though. I'd have
thought that shouldn't happen, as the table should be consistent with 
what's in the kernel routing table.
> > But the question is why wouldn't the route be added back to the  
> > kernel routing table again? I'm digging deep to find out why, but  
> > if anyone knows why this is happening then I'd really appreciate if  
> > you can help me out. Thank you in advanced.
> trying .. :)
I'm still not 100% sure what's causing the 2-hop route not to be added
to the kernel routing table again, but think I'll just blame it on the
fragmented TC message bug :)

More information about the Olsr-dev mailing list