[Olsr-users] the flex

Quanxin (spam-protected)
Mon May 16 11:50:42 CEST 2016

Hi all,
I am installing and building olsrd2 on Ubuntu(distribution 12.10) according to the guidance:

//a current build system (GCC, GNU-Make, ...)
//CMake version 2.8.12 or better
//libnl-3-dev (including libnl-genl-3-dev) or libnl-tiny for the nl80211-listener plugin
//libuci for the cfg_uciloader plugin
//libtomcrypt-dev for the hash_tomcrypt plugin

I met some annoying problems.
When I tried to install the libnl-3-dev, it said that the "bison" and "flex" were needed.
So I downloaded the flex-2.6.0 and tried.
But there was an error message:
//checking for m4 that supports -P... configure: error: could not find m4 that supports -P.

I searched on the web and it says the newer version of flex doesn't support Linux.
What should I do?


Best regards!
Sincerely yours
Zhang Quanxin

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.olsr.org/pipermail/olsr-users/attachments/20160516/6ea6800f/attachment.html>

More information about the Olsr-users mailing list