[Olsr-users] Looking for simple OLSRd2 config

Henning Rogge (spam-protected)
Wed Apr 29 19:17:09 CEST 2015


On Wed, Apr 29, 2015 at 6:55 PM, Bernd Naumann <(spam-protected)> wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Hi @all,
>
> I have build OpenWRT BB 14.04 with the oonf feed like explained on
> http://www.olsr.org/mediawiki/index.php/Olsrd2 but now I'm struggling on
> how to make it 'work'.
>
> For what I have understood, is that OLSRd2 have at least two components:
> the OLSR2 daemon, and dlep, which talks/translates between the radio and
> the daemon; is that correct? If not please explain it to me or point me
> to documentation. I just think the wiki is not complete at this point of
> development.
>
> However: It is said that when OLSRd2 is used not the wifi-interface has
> an ipaddr, but the local loopback device has an address (?!) which
> totally confuses me how this works.
>
> I have set up two tl-link routers with matching configuration, like:
>
> # cat /etc/config/wireless
> config wifi-device  radio0
>         option type     mac80211
>         option channel  11
>         option hwmode   11g
>         option path     'platform/ar934x_wmac'
>         option htmode   HT20
>         # REMOVE THIS LINE TO ENABLE WIFI:
>         # option disabled 1
>
> config wifi-iface
>         option device   radio0
>         option mode     adhoc
>         option ssid     Mesh-OLSRd2
>         option bssid    be:ca:ff:ee:ba:be
>         option network  lan
>         option encryption none
>
>
> ###############################################
> # cat /etc/config/network
>
> config interface 'loopback'
>         option ifname 'lo'
>         option proto 'static'
>         option ipaddr '127.0.0.1'
>         option netmask '255.0.0.0'
>
> config globals 'globals'
>         option ula_prefix 'fd::::/48'
>
> config interface 'lan'
>         option ifname 'eth1'
>         option force_link '1'
>         option type 'bridge'
>         option proto 'static'
>         option ipaddr '192.168.1.1'
>         option netmask '255.255.255.0'
>         option ip6assign '60'
>
> config interface 'wan'
>         option ifname 'eth0'
>         option proto 'dhcp'
>
> config interface 'wan6'
>         option ifname 'eth0'
>         option proto 'dhcpv6'
>
> config switch
>         option name 'switch0'
>         option reset '1'
>         option enable_vlan '1'
>
> config switch_vlan
>         option device 'switch0'
>         option vlan '1'
>         option ports '0 1 2 3 4'
>
> ###############################################
> # cat /etc/config/dlep_radio
...
I don't think you need the dlep_radio at all.

> ###############################################
> # cat /etc/config/olsrd2
> config global
>         option 'failfast'       'no'
>         option 'pidfile'        '/var/run/olsrd2.pid'
>         option 'lockfile'       '/var/lock/olsrd2'
>
> config log
>         option 'syslog'         'true'
>         option 'stderr'         'true'
>         option 'file'           '/var/log/olsrd2.log'
>         option 'info'           'all'
>         option 'debug'          'all'

This will spam your logfile pretty quickly... don't complain when you
have a few megabytes of log after a while.

> config telnet
>         option  'port'          '2009'
>
> config olsrv2
>         list    'lan'           '::/0'
> # list 'lan' '0.0.0.0/0'
>
> config interface
>         option 'ifname'         'loopback'
> #       option 'lan'            '10.0.2.1/24'

the "lan" option is not valid for the section "interface".

Maybe you are thinking about setting an IP address on the loopback in
the network config?

> config interface
>         list    'ifname'        'wlan0'
>
> config interface
>         list    'ifname'        'wan'
>         option 'ignore'         '1'
> #       option 'rx_bitrate' '100M'
> #       option 'tx_bitrate' '100M'
> #       option 'signal' '-20'
>
> config interface
>         list    'ifname'        'lan'
>         option  'ignore'        '1'
> #       option 'rx_bitrate' '1G'
> #       option 'tx_bitrate' '1G'
> #       option 'signal' '-10'

So you want both "lan" and "wan" a mesh interface?

> ###############################################
>
>
> dlep and olsrd2 start up via openwrt init.d scripts.

Why do you want to run dlep_radio?

> So my actual questions are:
>
> * Where do I configure an ip-address? Via config/network (or with
> `ip`), OR via config/olsrd2 ?

the idea is that you set the IP addresses via the network config.
Olsrd2 will monitor all its interfaces and automatically grab
addresses that are allowed (you can set patterns in the olsrd2-config
what is allowed).

run "olsrd2 --schema=interface.ifaddr_filter" for the rules which
addresses will be included in Hellos and "olsrd2
--schema=olsrv2.routable" for the rules which addresses will be
"routable" and distributed "end-to-end".

> * How do I check for mesh-neighbours? From olsr I know `wget -qO -
> http://127.0.0.1:2006/neighbours`...

Try the telnet port of olsrd2 (see config above ^^). e.g.:

echo /nhdpinfo neighbor | nc 127.0.0.1 2009

or connect to the telnet port and use the "help" command... e.g.

"help" (for generic help and a list of available commands)
"help <command>" for help text for an available command.

Henning




More information about the Olsr-users mailing list