[Olsr-users] Looking for simple OLSRd2 config

Bernd Naumann (spam-protected)
Wed Apr 29 18:55:33 CEST 2015


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi @all,

I have build OpenWRT BB 14.04 with the oonf feed like explained on
http://www.olsr.org/mediawiki/index.php/Olsrd2 but now I'm struggling on
how to make it 'work'.

For what I have understood, is that OLSRd2 have at least two components:
the OLSR2 daemon, and dlep, which talks/translates between the radio and
the daemon; is that correct? If not please explain it to me or point me
to documentation. I just think the wiki is not complete at this point of
development.

However: It is said that when OLSRd2 is used not the wifi-interface has
an ipaddr, but the local loopback device has an address (?!) which
totally confuses me how this works.

I have set up two tl-link routers with matching configuration, like:

# cat /etc/config/wireless
config wifi-device  radio0
	option type     mac80211
	option channel  11
	option hwmode	11g
	option path	'platform/ar934x_wmac'
	option htmode	HT20
	# REMOVE THIS LINE TO ENABLE WIFI:
	# option disabled 1

config wifi-iface
	option device   radio0
	option mode	adhoc
	option ssid	Mesh-OLSRd2
	option bssid	be:ca:ff:ee:ba:be
	option network	lan
	option encryption none


###############################################
# cat /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd::::/48'

config interface 'lan'
	option ifname 'eth1'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth0'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth0'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 4'

###############################################
# cat /etc/config/dlep_radio
config global
	option 'failfast'    'no'
	option 'pidfile'     '/var/run/dlep_radio.pid'
	option 'lockfile'    '/var/lock/dlep_radio'

config log
	option 'syslog'      'true'
	option 'stderr'      'true'
	option 'file'        '/var/log/dlep_radio.log'
	option 'info'        'all'
	option 'debug'       'all'

config telnet
	option 'port'        '2009'

config dlep_radio
	list   'name'        'wlan0'
	option 'datapath_if' 'br-lan'
	option 'not_proxied' 'false'
	option 'proxied'     'true'

config nl80211_listener
	option 'if'          'wlan0'
	option 'interval'    '1.0'

###############################################
# cat /etc/config/olsrd2
config global
	option 'failfast'	'no'
	option 'pidfile'	'/var/run/olsrd2.pid'
	option 'lockfile'	'/var/lock/olsrd2'

config log
	option 'syslog'		'true'
	option 'stderr'		'true'
	option 'file'		'/var/log/olsrd2.log'
	option 'info'		'all'
	option 'debug'		'all'

config telnet
	option 	'port' 		'2009'

config olsrv2
	list 	'lan' 		'::/0'
# list 'lan' '0.0.0.0/0'

config interface
	option 'ifname' 	'loopback'
#	option 'lan'		'10.0.2.1/24'

config interface
	list 	'ifname' 	'wlan0'

config interface
	list 	'ifname' 	'wan'
	option 'ignore' 	'1'
#	option 'rx_bitrate' '100M'
#	option 'tx_bitrate' '100M'
#	option 'signal' '-20'

config interface
	list 	'ifname' 	'lan'
	option 	'ignore' 	'1'
#	option 'rx_bitrate' '1G'
#	option 'tx_bitrate' '1G'
#	option 'signal' '-10'

###############################################


dlep and olsrd2 start up via openwrt init.d scripts.

So my actual questions are:

* Where do I configure an ip-address? Via config/network (or with
`ip`), OR via config/olsrd2 ?
* How do I check for mesh-neighbours? From olsr I know `wget -qO -
http://127.0.0.1:2006/neighbours`...

Thanks for any help, and maybe we will meetup at the WCW in 2 weeks :)
Greetings,
Bernd

- -- 
Bernd Naumann <(spam-protected)>

PGP:   0xA150A04F via pool.sks-keyservers.net
XMPP:  (spam-protected)

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.19 (GNU/Linux)

iQIcBAEBAgAGBQJVQQ0FAAoJEEYW3OihUKBPqbkP/3Z2tmsGVI3zsTuhGvsZibAw
q3jK2bD/YTEH0+k+2W3kB2NmJtb54I+0NU/VFX9XtC7SZbAhkz3CS2FhyPn/mgnb
AOszDVd3B0ntF5LYiYbfpIZEuP/O+aWPj1jhQDF7mbjTMd5vDcJSri4adUWSw8X8
9zZ5jBe6UXiDX3+nDGZWJSzaUmoGmCARAqtBWWpR9lPhO1Vqui7VfgREQJRHRVw1
NCNuPX0no5VW88JL2Q5CH+B+C6oPZ09ChyBHDkFQO3F95NKvcao7OWQznJZKGpAR
6DWlE5h65Q6+Bg2NPAY2HMNEhIc21YE9Kpb2/mJVDQk3shV1Q957wGSGQrMt2EUe
RTZJOgZ90bnp4MKhwbvoNU91V3DBCmAa6FjzoAw67w4smfXcKpOkdw3VscKStkSe
9brpxRPk15kCYok3uz641LfjxMeWnv0sOcFptvm47Z9RNhvf6MuhAJm/tUW5zbYV
CHKusk9uTL44Xe5dGlpCQforstJgj4iGIF6ST1uZRglYbAiksEnFTKss5eKYMW5p
v9TqJhdbkWSRYjF1xoi0J/krWi4jPzb3U06RpWf/R0bqbj4nuVe6XrDCwSddpvhv
T6Hwv4geY6NVfhAceOaIjuhBpcypLNGi1GOMYrbTOCttDAEkzQrgL++6I9V2aRMY
6pXfHS/3eZDVabJO2vXJ
=uy7G
-----END PGP SIGNATURE-----




More information about the Olsr-users mailing list