[Olsr-users] Configuration for olsrd.conf

ANDERSON JUNIOR GADO DA SILVA (spam-protected)
Sat Mar 1 13:07:19 CET 2014


hello, I'll post my settings olsr to take a look:

/etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'wlan'
        option network 'wlan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'wan'
        option network 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config forwarding
        option src 'wlan'
        option dest 'wan'

config forwarding
        option src 'lan'
        option dest 'wlan'

config forwarding
        option src 'wlan'
        option dest 'lan'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option target 'ACCEPT'
        option src 'wan'
        option proto 'tcp'
        option dest_port '22'


option include
        option path '/etc/firewall.user'

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option _orig_ifname 'eth0.2'
        option _orig_bridge 'false'
        option ifname 'eth0.2'
        option proto 'static'
        option ipaddr '192.168.254.2'
        option netmask '255.255.0.0'
        option gateway '192.168.254.254'
        option dns '10.4.0.1'

config switch
        option name 'rtl8366rb'
        option reset '1'
        option enable_vlan '1'
        option enable_vlan4k '1'

config switch_vlan
        option device 'rtl8366rb'
        option vlan '1'
        option ports '0t 1 2 3 4 5t'

config switch_vlan
        option device 'rtl8366rb'
        option vlan '2'
        option ports '0 5t'

config interface 'wlan'
        option _orig_ifname 'wlan0'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr '10.5.0.1'
        option netmask '255.255.0.0'
        option broadcast '10.5.255.255'
/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option macaddr 'f8:d1:11:56:8d:04'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'DSSS_CCK-40'
        option channel '9'
        option hwmode '11b'
        option txpower '24'
        option country 'BR'

config wifi-iface
        option device 'radio0'
        option encryption 'none'
        option ssid 'wscmobile'
        option mode 'adhoc'
        option bssid 'f8:d1:11:56:8d:04'
        option network 'wlan'

Here the output of this command

echo '/all' | nc localhost 2006
HTTP/1.0 200 OK
Content-type: text/plain

Table: Links
Local IP        Remote IP       Hyst.   LQ      NLQ     Cost

Table: Neighbors
IP address      SYM     MPR     MPRS    Will.   2 Hop Neighbors

Table: Topology
Dest. IP        Last hop IP     LQ      NLQ     Cost

Table: HNA
Destination     Gateway
0.0.0.0/0       10.5.0.1

Table: MID
IP address      Aliases

Table: Routes
Destination     Gateway IP      Metric  ETX     Interface


only one of the routers is connected, so ta ouotros not appearing in the
command

but this not browsing
Att
Anderson Junior


2014-03-01 4:51 GMT-04:00 Chris W. <(spam-protected)>:

> Two more settings should be taken into account,
>
> first is openwrt's firewall settings: forwarding between wan and wifi
> should be enabled in /etc/config/firewall
>
> config forwarding
>     option src      wlan0
>     option dest     wan
>
> second is olsrd's HNA entry to announce the way out,
> the olsrd_dyn_gw should take care about it. Check with
> echo ""/all"" | nc localhost 2006, any "0.0.0.0/0" on the list?
>
> btw. this is still without using smart gateway.
>
> greetings,
> Chris
>
>
> On 02/28/2014 01:12 PM, ANDERSON JUNIOR GADO DA SILVA wrote:
>
>> hello, all devices are as adhoc and also with olsr running, my doubt is
>> now in gatwey settings that will provide internet, I'll post the
>> official list openwrt because I think it is an issue that refers to
>> openwrt, I believe qu must be a mistake to share the internet to the wan
>> wifi0
>>
>> Att
>> Anderson Junior
>>
>>
>> 2014-02-28 5:08 GMT-04:00 Henning Rogge <(spam-protected)
>> <mailto:(spam-protected)>>:
>>
>>
>>     Hi,
>>
>>     so you now have connectivity between all nodes, even if they are not
>>     all in direct range (OLSR should forward the traffic hop by hip)?
>>
>>     Henning
>>
>>     On Thu, Feb 27, 2014 at 5:26 PM, ANDERSON JUNIOR GADO DA SILVA
>>     <(spam-protected) <mailto:(spam-protected)>> wrote:
>>      > hello, thanks for the help so far, the 3 devices are talking to
>>     each other,
>>      > were with the ips so, 10.5.0.1, 10.5.0.2 and 10.5.0.3, but still
>>     no internet
>>      > connection, I must choose one of openwrt and configure the wan,
>>     still do not
>>      > see a way out in order to use pppoe authentication or captive
>>     (hotspot)
>>      > portal.
>>      >
>>      > Att
>>      > Anderson Junior
>>      >
>>      >
>>      > 2014-02-27 11:19 GMT-04:00 Chris W. <(spam-protected)
>>     <mailto:(spam-protected)>>:
>>
>>      >
>>      >> Hello,
>>      >>
>>      >> an ip-bridge is not too useful with olsr,
>>      >> the router's lan might be in a separate subnet which gets
>>     announced via
>>      >> olsrd.conf's HNA entry.
>>      >> In this case all radios are in the 192.168.2.x subnet and
>>      >> all lans are in 192.168.x.0/24 so the routing remains simple.
>>      >>
>>      >>
>>      >> /etc/config/network:
>>      >>
>>      >> config interface 'lan'
>>      >>         option ifname 'eth1'
>>      >>         option proto 'static'
>>      >>         option ipaddr '192.168.47.1'
>>      >>         option netmask '255.255.255.0'
>>      >>
>>      >> config interface 'wlan0'
>>      >>         option proto 'static'
>>      >>         option ipaddr '192.168.2.47'
>>      >>         option netmask '255.255.255.0'
>>      >>
>>      >> /etc/config/wireless:
>>      >>
>>      >> config wifi-iface
>>      >>         option device 'radio0'
>>      >>         option mode 'adhoc'
>>      >>         option ssid 'somename'
>>      >>         option bssid '00:10:20:30:40:70'
>>      >>         option network 'wlan0'
>>      >>
>>      >> Good luck :)
>>      >>
>>      >> Chris
>>      >>
>>      >>
>>      >>
>>      >> On 02/27/2014 01:16 PM, ANDERSON JUNIOR GADO DA SILVA wrote:
>>      >>>
>>      >>> Hello, researching more about the ad-hoc mode, it does not
>>     support so I
>>      >>> need to configure a bridge ip to it, I have done that and now I'm
>>      >>> conceguindo access the radio and also dribbling it, knowing now
>>     that he
>>      >>> does not accept bridge'm looking for an outlet for the mac
>>     computer that
>>      >>> will make the connection arrives on the server because the
>>      >>> authentication is via PPPoE, I'm still very confused but already
>>      >>> beginning to understand, you have any suggestions for the network
>>      >>> topology?
>>      >>>
>>      >>> Att
>>      >>> Anderson Junior
>>      >>>
>>      >>>
>>      >>> 2014-02-27 4:07 GMT-04:00 Henning Rogge
>>      >>> <(spam-protected)
>>     <mailto:(spam-protected)>
>>      >>> <mailto:(spam-protected)
>>
>>     <mailto:(spam-protected)>>>:
>>      >>>
>>      >>>
>>      >>>     On 02/26/2014 08:58 PM, ANDERSON JUNIOR GADO DA SILVA wrote:
>>      >>>      > Good afternoon, I was in doubt if I should start a new
>>      >>>     conversation so
>>      >>>      > I'm posting here again.
>>      >>>      >
>>      >>>      > without making any changes to the file connected the
>>     router and
>>      >>>      > connected directly to link a computer in wireless ad-hoc
>>      >>>     wireless, but
>>      >>>      > when I'm by wireless concigo not ping even access the
>>     router,
>>      >>>     only when
>>      >>>      > connected directly by cable, any hint is well Welcome.
>>      >>>
>>      >>>     Even before you start the routing daemon you should be able
>>     to ping
>>      >>> your
>>      >>>     direct neighbors. If this doesn't work your wifi/interface
>>      >>> configuration
>>      >>>     is bugged.
>>      >>>
>>      >>>     So I would advise to test the connectivity of your network
>>     without
>>      >>> olsrd
>>      >>>     first.
>>      >>>
>>      >>>     See
>>      >>> http://www.olsr.org/mediawiki/index.php/First_Mesh_
>> Troubleshooting
>>      >>>
>>      >>>     Henning Rogge
>>      >>>
>>      >>>
>>      >>>     --
>>      >>>     Diplom-Informatiker Henning Rogge , Fraunhofer-Institut für
>>      >>>     Kommunikation, Informationsverarbeitung und Ergonomie FKIE
>>      >>>     Kommunikationssysteme (KOM)
>>      >>>     Fraunhofer Straße 20, 53343 Wachtberg, Germany
>>      >>>     Telefon +49 228 9435-961 <tel:%2B49%20228%209435-961>
>>     <tel:%2B49%20228%209435-961>,   Fax +49 228
>>      >>>     9435 685 <tel:%2B49%20228%209435%20685>
>>      >>>     mailto:(spam-protected)
>>     <mailto:(spam-protected)>
>>      >>>
>>      >>>     <mailto:(spam-protected)
>>     <mailto:(spam-protected)>>
>>      >>> http://www.fkie.fraunhofer.de
>>      >>>
>>      >>>
>>      >>>     --
>>      >>>     Olsr-users mailing list
>>      >>> (spam-protected) <mailto:(spam-protected)>
>>     <mailto:(spam-protected) <mailto:(spam-protected)>>
>>
>>      >>> https://lists.olsr.org/mailman/listinfo/olsr-users
>>      >>>
>>      >>>
>>      >>>
>>      >>>
>>      >>>
>>      >>>
>>      >>
>>      >> --
>>      >> Olsr-users mailing list
>>      >> (spam-protected) <mailto:(spam-protected)>
>>      >> https://lists.olsr.org/mailman/listinfo/olsr-users
>>      >
>>      >
>>      >
>>      > --
>>      > Olsr-users mailing list
>>      > (spam-protected) <mailto:(spam-protected)>
>>      > https://lists.olsr.org/mailman/listinfo/olsr-users
>>
>>
>>
>>
>>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.olsr.org/pipermail/olsr-users/attachments/20140301/91782384/attachment.html>


More information about the Olsr-users mailing list