<div dir="ltr"><span id="result_box" class="" lang="en"><span class="">hello</span><span>, I'll post</span> <span class="">my</span> <span class="">settings</span> <span class="">olsr</span> <span class="">to</span> <span class="">take a look</span><span>:</span> <br>
<br>/etc/config/firewall <br><br>config defaults<br> option syn_flood '1'<br> option input 'ACCEPT'<br> option output 'ACCEPT'<br> option forward 'REJECT'<br><br>
config zone<br> option name 'lan'<br> option network 'lan'<br> option input 'ACCEPT'<br> option output 'ACCEPT'<br> option forward 'REJECT'<br><br>
config zone<br> option name 'wlan'<br> option network 'wlan'<br> option input 'ACCEPT'<br> option output 'ACCEPT'<br> option forward 'REJECT'<br><br>
config zone<br> option name 'wan'<br> option network 'wan'<br> option input 'REJECT'<br> option output 'ACCEPT'<br> option forward 'REJECT'<br> option masq '1'<br>
<br>config forwarding<br> option src 'lan'<br> option dest 'wan'<br><br>config forwarding<br> option src 'wlan'<br> option dest 'wan'<br><br>config forwarding<br>
option src 'lan'<br> option dest 'wlan'<br><br>config forwarding<br> option src 'wlan'<br> option dest 'lan'<br><br>config rule<br> option name 'Allow-Ping'<br>
option src 'wan'<br> option proto 'icmp'<br> option icmp_type 'echo-request'<br> option family 'ipv4'<br> option target 'ACCEPT'<br><br>config rule<br>
option target 'ACCEPT'<br> option src 'wan'<br> option proto 'tcp'<br> option dest_port '22'<br><br><br>option include<br> option path '/etc/firewall.user'<br>
<br>/etc/config/network<br><br>config interface 'loopback'<br> option ifname 'lo' <br> option proto 'static'<br> option ipaddr '127.0.0.1'<br> option netmask '255.0.0.0'<br>
<br>config interface 'lan'<br> option ifname 'eth0.1'<br> option proto 'static' <br> option ipaddr '192.168.1.1'<br> option netmask '255.255.255.0'<br><br>
config interface 'wan'<br> option _orig_ifname 'eth0.2'<br> option _orig_bridge 'false'<br> option ifname 'eth0.2'<br> option proto 'static'<br> option ipaddr '192.168.254.2'<br>
option netmask '255.255.0.0'<br> option gateway '192.168.254.254'<br> option dns '10.4.0.1'<br><br>config switch<br> option name 'rtl8366rb'<br> option reset '1'<br>
option enable_vlan '1'<br> option enable_vlan4k '1'<br><br>config switch_vlan<br> option device 'rtl8366rb'<br> option vlan '1'<br> option ports '0t 1 2 3 4 5t'<br>
<br>config switch_vlan<br> option device 'rtl8366rb'<br> option vlan '2'<br> option ports '0 5t'<br><br>config interface 'wlan'<br> option _orig_ifname 'wlan0'<br>
option _orig_bridge 'false'<br> option proto 'static'<br> option ipaddr '10.5.0.1'<br> option netmask '255.255.0.0'<br> option broadcast '10.5.255.255'<br>
/etc/config/wireless<br><br>config wifi-device 'radio0'<br> option type 'mac80211'<br> option macaddr 'f8:d1:11:56:8d:04'<br> list ht_capab 'SHORT-GI-40'<br> list ht_capab 'DSSS_CCK-40'<br>
option channel '9'<br> option hwmode '11b'<br> option txpower '24'<br> option country 'BR'<br><br>config wifi-iface<br> option device 'radio0'<br>
option encryption 'none'<br> option ssid 'wscmobile'<br> option mode 'adhoc'<br> option bssid 'f8:d1:11:56:8d:04'<br> option network 'wlan'<br><br>
<span class="">Here</span> <span class="">the output of</span> <span class="">this</span> <span class="">command</span> <br><br>echo '/all' | nc localhost 2006<br>HTTP/1.0 200 OK<br>Content-type: text/plain<br><br>
Table: Links<br>Local IP Remote IP Hyst. LQ NLQ Cost<br><br>Table: Neighbors<br>IP address SYM MPR MPRS Will. 2 Hop Neighbors<br><br>Table: Topology<br>Dest. IP Last hop IP LQ NLQ Cost<br>
<br>Table: HNA<br>Destination Gateway<br><a href="http://0.0.0.0/0">0.0.0.0/0</a> 10.5.0.1<br><br>Table: MID<br>IP address Aliases<br><br>Table: Routes<br>Destination Gateway IP Metric ETX Interface<br>
<br></span><br><span id="result_box" class="" lang="en"><span id="result_box" class="" lang="en"><span class="">only</span> <span class="">one of the routers</span> <span class="">is connected</span><span>, so</span> <span class="">ta</span> <span class="">ouotros</span> <span class="">not appearing</span> <span class="">in</span> <span class="">the</span> <span class="">command<br>
<br></span></span><span class="">but this</span> <span class="">not browsing</span> <br><span class="">Att</span> <br><span class="">Anderson</span> <span class="">Junior</span></span><div class="gmail_extra"><br><br><div class="gmail_quote">
2014-03-01 4:51 GMT-04:00 Chris W. <span dir="ltr"><<a href="mailto:chris-wy@web.de" target="_blank">chris-wy@web.de</a>></span>:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div class="">Two more settings should be taken into account,<br>
<br>
first is openwrt's firewall settings: forwarding between wan and wifi should be enabled in /etc/config/firewall<br>
<br>
config forwarding<br>
option src wlan0<br>
option dest wan<br>
<br>
second is olsrd's HNA entry to announce the way out,<br>
the olsrd_dyn_gw should take care about it. Check with<br>
echo ""/all"" | nc localhost 2006, any "<a href="http://0.0.0.0/0" target="_blank">0.0.0.0/0</a>" on the list?<br>
<br>
btw. this is still without using smart gateway.<br>
<br>
greetings,<br>
Chris<br>
<br>
<br></div><div class="">
On 02/28/2014 01:12 PM, ANDERSON JUNIOR GADO DA SILVA wrote:<br>
</div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div class="">
hello, all devices are as adhoc and also with olsr running, my doubt is<br>
now in gatwey settings that will provide internet, I'll post the<br>
official list openwrt because I think it is an issue that refers to<br>
openwrt, I believe qu must be a mistake to share the internet to the wan<br>
wifi0<br>
<br>
Att<br>
Anderson Junior<br>
<br>
<br>
2014-02-28 5:08 GMT-04:00 Henning Rogge <<a href="mailto:hrogge@gmail.com" target="_blank">hrogge@gmail.com</a><br></div>
<mailto:<a href="mailto:hrogge@gmail.com" target="_blank">hrogge@gmail.com</a>>>:<div class=""><br>
<br>
Hi,<br>
<br>
so you now have connectivity between all nodes, even if they are not<br>
all in direct range (OLSR should forward the traffic hop by hip)?<br>
<br>
Henning<br>
<br>
On Thu, Feb 27, 2014 at 5:26 PM, ANDERSON JUNIOR GADO DA SILVA<br></div><div class="">
<<a href="mailto:andersonscinfo@gmail.com" target="_blank">andersonscinfo@gmail.com</a> <mailto:<a href="mailto:andersonscinfo@gmail.com" target="_blank">andersonscinfo@gmail.<u></u>com</a>>> wrote:<br>
> hello, thanks for the help so far, the 3 devices are talking to<br>
each other,<br>
> were with the ips so, 10.5.0.1, 10.5.0.2 and 10.5.0.3, but still<br>
no internet<br>
> connection, I must choose one of openwrt and configure the wan,<br>
still do not<br>
> see a way out in order to use pppoe authentication or captive<br>
(hotspot)<br>
> portal.<br>
><br>
> Att<br>
> Anderson Junior<br>
><br>
><br>
> 2014-02-27 11:19 GMT-04:00 Chris W. <<a href="mailto:chris-wy@web.de" target="_blank">chris-wy@web.de</a><br></div>
<mailto:<a href="mailto:chris-wy@web.de" target="_blank">chris-wy@web.de</a>>>:<div><div class="h5"><br>
><br>
>> Hello,<br>
>><br>
>> an ip-bridge is not too useful with olsr,<br>
>> the router's lan might be in a separate subnet which gets<br>
announced via<br>
>> olsrd.conf's HNA entry.<br>
>> In this case all radios are in the 192.168.2.x subnet and<br>
>> all lans are in 192.168.x.0/24 so the routing remains simple.<br>
>><br>
>><br>
>> /etc/config/network:<br>
>><br>
>> config interface 'lan'<br>
>> option ifname 'eth1'<br>
>> option proto 'static'<br>
>> option ipaddr '192.168.47.1'<br>
>> option netmask '255.255.255.0'<br>
>><br>
>> config interface 'wlan0'<br>
>> option proto 'static'<br>
>> option ipaddr '192.168.2.47'<br>
>> option netmask '255.255.255.0'<br>
>><br>
>> /etc/config/wireless:<br>
>><br>
>> config wifi-iface<br>
>> option device 'radio0'<br>
>> option mode 'adhoc'<br>
>> option ssid 'somename'<br>
>> option bssid '00:10:20:30:40:70'<br>
>> option network 'wlan0'<br>
>><br>
>> Good luck :)<br>
>><br>
>> Chris<br>
>><br>
>><br>
>><br>
>> On 02/27/2014 01:16 PM, ANDERSON JUNIOR GADO DA SILVA wrote:<br>
>>><br>
>>> Hello, researching more about the ad-hoc mode, it does not<br>
support so I<br>
>>> need to configure a bridge ip to it, I have done that and now I'm<br>
>>> conceguindo access the radio and also dribbling it, knowing now<br>
that he<br>
>>> does not accept bridge'm looking for an outlet for the mac<br>
computer that<br>
>>> will make the connection arrives on the server because the<br>
>>> authentication is via PPPoE, I'm still very confused but already<br>
>>> beginning to understand, you have any suggestions for the network<br>
>>> topology?<br>
>>><br>
>>> Att<br>
>>> Anderson Junior<br>
>>><br>
>>><br>
>>> 2014-02-27 4:07 GMT-04:00 Henning Rogge<br>
>>> <<a href="mailto:henning.rogge@fkie.fraunhofer.de" target="_blank">henning.rogge@fkie.<u></u>fraunhofer.de</a><br>
<mailto:<a href="mailto:henning.rogge@fkie.fraunhofer.de" target="_blank">henning.rogge@fkie.<u></u>fraunhofer.de</a>><br></div></div>
>>> <mailto:<a href="mailto:henning.rogge@fkie.fraunhofer.de" target="_blank">henning.rogge@fkie.<u></u>fraunhofer.de</a><div><div class="h5"><br>
<mailto:<a href="mailto:henning.rogge@fkie.fraunhofer.de" target="_blank">henning.rogge@fkie.<u></u>fraunhofer.de</a>>>>:<br>
>>><br>
>>><br>
>>> On 02/26/2014 08:58 PM, ANDERSON JUNIOR GADO DA SILVA wrote:<br>
>>> > Good afternoon, I was in doubt if I should start a new<br>
>>> conversation so<br>
>>> > I'm posting here again.<br>
>>> ><br>
>>> > without making any changes to the file connected the<br>
router and<br>
>>> > connected directly to link a computer in wireless ad-hoc<br>
>>> wireless, but<br>
>>> > when I'm by wireless concigo not ping even access the<br>
router,<br>
>>> only when<br>
>>> > connected directly by cable, any hint is well Welcome.<br>
>>><br>
>>> Even before you start the routing daemon you should be able<br>
to ping<br>
>>> your<br>
>>> direct neighbors. If this doesn't work your wifi/interface<br>
>>> configuration<br>
>>> is bugged.<br>
>>><br>
>>> So I would advise to test the connectivity of your network<br>
without<br>
>>> olsrd<br>
>>> first.<br>
>>><br>
>>> See<br>
>>> <a href="http://www.olsr.org/mediawiki/index.php/First_Mesh_Troubleshooting" target="_blank">http://www.olsr.org/mediawiki/<u></u>index.php/First_Mesh_<u></u>Troubleshooting</a><br>
>>><br>
>>> Henning Rogge<br>
>>><br>
>>><br>
>>> --<br>
>>> Diplom-Informatiker Henning Rogge , Fraunhofer-Institut für<br>
>>> Kommunikation, Informationsverarbeitung und Ergonomie FKIE<br>
>>> Kommunikationssysteme (KOM)<br>
>>> Fraunhofer Straße 20, 53343 Wachtberg, Germany<br>
>>> Telefon <a href="tel:%2B49%20228%209435-961" value="+492289435961" target="_blank">+49 228 9435-961</a> <tel:%2B49%20228%209435-961><br>
<tel:%2B49%20228%209435-961>, Fax +49 228<br>
>>> 9435 685 <tel:%2B49%20228%209435%20685><br>
>>> mailto:<a href="mailto:henning.rogge@fkie.fraunhofer.de" target="_blank">henning.rogge@fkie.<u></u>fraunhofer.de</a><br>
<mailto:<a href="mailto:henning.rogge@fkie.fraunhofer.de" target="_blank">henning.rogge@fkie.<u></u>fraunhofer.de</a>><br>
>>><br>
>>> <mailto:<a href="mailto:henning.rogge@fkie.fraunhofer.de" target="_blank">henning.rogge@fkie.<u></u>fraunhofer.de</a><br>
<mailto:<a href="mailto:henning.rogge@fkie.fraunhofer.de" target="_blank">henning.rogge@fkie.<u></u>fraunhofer.de</a>>><br>
>>> <a href="http://www.fkie.fraunhofer.de" target="_blank">http://www.fkie.fraunhofer.de</a><br>
>>><br>
>>><br>
>>> --<br>
>>> Olsr-users mailing list<br>
>>> <a href="mailto:Olsr-users@lists.olsr.org" target="_blank">Olsr-users@lists.olsr.org</a> <mailto:<a href="mailto:Olsr-users@lists.olsr.org" target="_blank">Olsr-users@lists.olsr.<u></u>org</a>><br>
</div></div>
<mailto:<a href="mailto:Olsr-users@lists.olsr.org" target="_blank">Olsr-users@lists.olsr.<u></u>org</a> <mailto:<a href="mailto:Olsr-users@lists.olsr.org" target="_blank">Olsr-users@lists.olsr.<u></u>org</a>>><div class="">
<br>
>>> <a href="https://lists.olsr.org/mailman/listinfo/olsr-users" target="_blank">https://lists.olsr.org/<u></u>mailman/listinfo/olsr-users</a><br>
>>><br>
>>><br>
>>><br>
>>><br>
>>><br>
>>><br>
>><br>
>> --<br>
>> Olsr-users mailing list<br>
>> <a href="mailto:Olsr-users@lists.olsr.org" target="_blank">Olsr-users@lists.olsr.org</a> <mailto:<a href="mailto:Olsr-users@lists.olsr.org" target="_blank">Olsr-users@lists.olsr.<u></u>org</a>><br>
>> <a href="https://lists.olsr.org/mailman/listinfo/olsr-users" target="_blank">https://lists.olsr.org/<u></u>mailman/listinfo/olsr-users</a><br>
><br>
><br>
><br>
> --<br>
> Olsr-users mailing list<br>
> <a href="mailto:Olsr-users@lists.olsr.org" target="_blank">Olsr-users@lists.olsr.org</a> <mailto:<a href="mailto:Olsr-users@lists.olsr.org" target="_blank">Olsr-users@lists.olsr.<u></u>org</a>><br>
> <a href="https://lists.olsr.org/mailman/listinfo/olsr-users" target="_blank">https://lists.olsr.org/<u></u>mailman/listinfo/olsr-users</a><br>
<br>
<br>
<br>
<br></div></blockquote></blockquote></div><br></div></div>