[Olsr-users] OLSRd Runtime Issue

Joshua McKee (spam-protected)
Thu Aug 1 04:03:44 CEST 2013


I'm having a strange issue with OLSRd. When I run it on a system with
Ubuntu Server (12.04.2), it runs fine. When I run it on Ubuntu Desktop
(12.04.2 and above) with same configuration, on the same hardware, I get
this error message:
Checking wlan0:
    Interface not up & running - skipping it...
No interfaces detected! This might be intentional, but it also might mean
that your configuration is fubar.
ifconfig shows that the interface is up, and the only difference is between
Ubuntu Desktop and Ubuntu Server.

I'm running OLSR v0.6.5.4

The command I run is:
$ sudo ./olsrd -i wlan0 -f olsrd.conf

My olsrd.conf file is empty.

Does anyone have any idea what's causing this?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.olsr.org/pipermail/olsr-users/attachments/20130731/5acd7b98/attachment.html>

More information about the Olsr-users mailing list