[Olsr-users] olsr position update plugin configuration

Bidur Devkota (spam-protected)
Fri Nov 30 16:23:49 CET 2012

Sorry, I missed to state some more observations:
I tried to provide random locations (programmatically) via the NMEA
statements to UDP port 2240, But the updates were not seen until the olsrd
is restarted. Also tried to change the values in positionFile , and the
updates were not seen until restarting the olsrd. (after updating the olsr
and pud from  <git clone git://olsr.org/olsrd.git> also the result is the
same )

Needless to say, I am learning a lot and I will prepare a how-to text about
this position update task after I go through it  successfully.


On Fri, Nov 30, 2012 at 10:12 PM, Bidur Devkota <(spam-protected)>wrote:

> Hi Ferry,
>> It's now implemented on the master branch.
> I cloned the olsr code from <git clone git://olsr.org/olsrd.git> and
> re-instailed OLSR and all the Plugins but I am able to observe the
> positions be loaded at olsrd startup only.
>  I even tried  re-installing from <git clone http://olsr.org/git/olsrd.git>.
> but got the same thing.
>  Am I missing something or something else.
> And the example provided by Teco, I tried to observe the tcpdump and could
> see the position information being circulated in the olsr network.
>> tcpdump -nlAs 0 -i $lan udp port 2240 | grep NBSX
> I tried to change the parameter value to 5 seconds for all these
> parameters and
>  "updateIntervalStationary", "updateIntervalMoving", "uplinkUpdateIntervalMoving","uplinkUpdateIntervalStationary"
> Also changed,
> "movingSpeedThreshold"  and "movingDistanceThreshold" to 1.
> But still to load the updated location information, I have to restart the
> olsrd.
> Thanking You,
> Bidur

Bidur Devkota
Asian Institute of Technology, Thailand
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.olsr.org/pipermail/olsr-users/attachments/20121130/a2a07a7a/attachment.html>

More information about the Olsr-users mailing list