[Olsr-users] BMF Plugin

Henning Rogge (spam-protected)
Thu Jan 29 12:22:16 CET 2009

Am Thursday 29 January 2009 11:38:47 schrieb Bhat, Ishwara:
> When I try bmf version 1.6.2 (which is the latest official release
> compatible with olsr-0.5.6-r2 ) I am getting compiler error   -
> undefined symbol - 'olsr_mutex'.
There are some external bmf versions that try to patch the olsr-core... so 
they are incompatible with MOST olsr versions (except the specific version the 
patch was created with).

> I am using Fedora core 9. (2.6.25) Also I tried kernel.
> When I tried with older version of olsr and bmf- 1.5.3 version (The
> default BMF version that comes with OLSRd-0.5.6),  I got tun error:
> ioctl error on /dev/net/tun: invalid argument.
> I have enabled TUN/TAP in linux. But somehow lsmod does not list tun.
What happens if you call 'modprobe tun' ? Do you see the tun module with 
'lsmod' after this ?

Henning Rogge

Diplom Informatiker Henning Rogge
Forschungsgesellschaft für
Angewandte Naturwissenschaften e. V. (FGAN) 
Neuenahrer Str. 20, 53343 Wachtberg, Germany
Tel.: 0049 (0)228 9435-961
Fax: 0049 (0)228 9435-685
E-Mail: (spam-protected)
Web: www.fgan.de
Sitz der Gesellschaft: Bonn
Registergericht: Amtsgericht Bonn VR 2530
Vorstand: Dr. rer. nat. Ralf Dornhaus (Vors.), Prof. Dr. Joachim Ender 

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part.
URL: <http://lists.olsr.org/pipermail/olsr-users/attachments/20090129/1f8c727d/attachment.sig>

More information about the Olsr-users mailing list