[Olsr-users] routing problems
Erik Tromp
(spam-protected)
Thu Feb 21 21:09:36 CET 2008
To answer your question I'd like to see the routing table on
each of the nodes, while OLSR is running. Just type
'route -n' at the prompt.
Apparently, also, you are bridging wired to wireless ('ath0 is
an ap on each node and it is bridged to lan'). Bridging from
wired-ethernet to wireless-802.11 raises some special issues,
especially in a routed network that you are using. The basic
problem is that, in an 802.11 a-hoc network, the unicast packets
are sent via an acknowledged protocol. This requires each radio
to keep a state with each of its neighbors in the WLAN.
Neighbors are kept by their MAC adress - that is:
802.11 MAC. What about the Ethernet MAC addresses at the wired
side of the bridge? No-one knowns, and certainly not your WLAN
driver.
Some bridge implementations recognize this situation, and tweak
the MAC addresses from the packets as they flow from the wired
side to the wireless side of the bridge and vice versa, translating
wired MAC addresses to wireless MAC addresses. In order to
make the translation, the IP address inside each packet is
recorded in a table, together with the corresponding MAC address.
But this tweak does not work in routed networks, where the IP
addresses the packets may actually be on another LAN.
I would advise you to not bridge from wired to wireless in a
routed network.
Erik
________________________________
Van: (spam-protected) [mailto:(spam-protected)] Namens Mark Kelly
Verzonden: dinsdag 19 februari 2008 4:31
Aan: (spam-protected)
Onderwerp: [Olsr-users] routing problems
Hello,
I've configured 0.5.5 under openwrt and I'm seeing some weird problems.
my olsrd.conf looks like this:
DebugLevel 0
IpVersion 4
ClearScreen yes
Hna4
{
#0.0.0.0 0.0.0.0
192.168.1.0 255.255.255.0
}
AllowNoInt yes
IpcConnect
{
MaxConnections 0
Host 127.0.0.1
}
UseHysteresis no
HystScaling 0.50
HystThrHigh 0.80
HystThrLow 0.30
Pollrate 0.1
TcRedundancy 2
MprCoverage 7
LinkQualityFishEye 1
LinkQualityWinSize 100
LinkQualityDijkstraLimit 0 6.0
LinkQualityLevel 2
NicChgsPollInt 3.0
Interface "ath1"
{
AutoDetectChanges yes
}
LoadPlugin "olsrd_httpinfo.so.0.1"
{
PlParam "port" "1979"
PlParam "Net" "0.0.0.0 0.0.0.0"
# PlParam "Net" "10.10.0.0 255.255.255.0"
PlParam "Net" "192.168.0.0 255.255.0.0"
}
my /etc/config/network:
config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
config interface lan
option ifname 'eth0 eth1'
option proto 'static'
option ipaddr '192.168.1.20'
option netmask '255.255.255.0'
option dns '192.168.1.1'
option gateway '192.168.1.1'
option type 'bridge'
config interface wan
#option ifname none
option proto static
option ipaddr 10.10.0.20
option netmask 255.255.255.0
option broadcast 10.10.0.255
and I've configured the others nodes with appropriate IP's and subnets (192.168.2.x and 10.10.0.x)
ath1 is my olsr mesh and it is tied to wan. ath0 is an ap on each node and it is bridged to lan.
my if I'm on node 2 which has an IP of 192.168.2.21, I can ping all of my other node 10.10.0.x addresses and I
can ping the IP assigned to the br-lan interface on each node, 192.168.3.x, 4.x, etc. Now the problem that I'm seeing
is that there are other clients attached on the lan interfaces. 192.168.1.20 is the node ip for #1 one on also on that
lan switch is 192.168.1.41 and 192.168.1.1. Now from any other node I can ping 192.168.1.20, but none of the others are
pingable, the ping command never ever says destination unreachable, it just sits there. Anyone got any ideas?
More information about the Olsr-users
mailing list