[OLSR-users] secure plugin questions in 0.4.9

Andreas T√łnnesen (spam-protected)
Tue Apr 19 18:51:05 CEST 2005


the plugin uses MD5 bu default. To use OpenSSL SHA-1
you must do:
make USE_OPENSSL=1

It does not support any other algorithms then SHA-1 and MD5.

- Andreas

(spam-protected) wrote:
> Thanks for help.
> 
> I have some questions in secure plugin.
> 
> By default, does it use /usr/include/openssl/sha.h for
> the encryption of digital signature?
> If sha.h is not found, then it will use
> /usr/include/md5. Am I right?
> 
> If I want to use md5 instead of sha, do I just rename
> the sha.h to sha.h.bak? So it will use md5?
> 
> Is it possible to use other algorithms, e.g. RIPEMD160
> and SHA256 by modifying the source code?
> 
> Thanks again.
> 
> James
> 
> 
> 		
> __________________________________ 
> Do you Yahoo!? 
> Plan great trips with Yahoo! Travel: Now over 17,000 guides!
> http://travel.yahoo.com/p-travelguide
> _______________________________________________
> olsr-users mailing list
> (spam-protected)
> https://www.olsr.org/mailman/listinfo/olsr-users

-- 
Andreas T√łnnesen
http://www.olsr.org



More information about the Olsr-users mailing list