[OLSR-users] Debug 1 required to work?

Andrew Nott (spam-protected)
Sat Jun 26 14:51:50 CEST 2004

Hi all,

I've just started playing with OLSR, at this stage I have olsrd running 
on a pair of Linksys WRT54G boxes with OpenWRT b4 - currently I'm using 
the ipkgs of 0.4.3 packaged by John Gorkos and available through Marc 
Quinton's repository.

When I run olsrd -d 1, and everything appears to work perfectly. The 
neighbour lists are updated and host routes appear for the other box. 
Then the dynamic gateway plugin detects that one has a route to the net, 
and the other box has a default route set via the gateway.

However, when I run olsrd with no debug arguments, things are a little 
different. The daemon detaches, three olsrd processes appear in the 
process listing, but no route updates happen.

With one copy of olsrd set to debug 1 and the other debug 0 the debug 
prints look almost right. Willingness is changed from 0 to 3, the other 
box appears in the neighbour list, the link is set to NOT pending, and I 
get HELLO timeouts when the second copy goes down, etc etc. But the 
neighbour list status flags remain l=0:m=0:w=3, rather than changing to 
l=1:m=0:w=3 as they do after the link is set to not pending with both 
daemons in debug mode, and no routes are added on either box.

Any ideas?

Andrew Nott

More information about the Olsr-users mailing list