[Olsr-dev] Olsrd2 (OONF) Release v.0.6.0

Henning Rogge (spam-protected)
Wed Nov 19 10:06:46 CET 2014

Can you run a "olsrd2_static --version" please?

I will try to reproduce things here.

Henning Rogge

On Wed, Nov 19, 2014 at 5:37 AM, Vigneswaran R <(spam-protected)> wrote:
> On 11/18/2014 05:43 PM, Henning Rogge wrote:
>> On Tue, Nov 18, 2014 at 1:10 PM, Vigneswaran R <(spam-protected)>
>> wrote:
>>> Hello,
>>> I noticed that the latest olsrd2 (built from unified 'oonf' git repo) is
>>> not
>>> listening on the UDP port 269, thus not establishing any routes. On the
>>> other hand, if I build the olsrd2 from olsrd2, oonf_api reporsitories, it
>>> is
>>> working properly. Am I missing something?
>>> (I am not using any configuration files. Just specifying the interface
>>> name
>>> in the command line).
>> I just noticed (yesterday evening) some trouble with the static builds
>> (some missing plugins) and pushed a fix.
>> Can you build the current commit again from the oonf-repository?
>> oonf_api and olsrd2 repositories should not be necessary.
>> I was thinking about releasing 0.6.1 this weekend because of the
>> problem but was still not finished testing.
> Still facing the problem. Tried running olsrd2_static using strace. It looks
> like, the daemon is not using the Interface name specified in the command
> line. eg.,
>     /usr/local/bin/olsrd2_static tap0
> I tried testing by putting the interface name in a configuration file.
> However, I got the following error.
>     # /usr/local/bin/olsrd2_static -l olsrd2.conf
>     Cannot find loader for parameter 'Compact'
>     Error, unknown config io 'olsrd2.conf'.
> The configuration file olsrd2.conf has the following line.
>     [interface=tap0]
> Vignesh

More information about the Olsr-dev mailing list