[Olsr-dev] [Olsr-users] [SUGGESTION] Interface no up and/or running

Ferry Huberts (spam-protected)
Mon Jun 17 09:35:47 CEST 2013

On 17/06/13 09:11, Henning Rogge wrote:
> On 06/14/2013 11:31 AM, Henning Rogge wrote:
>> On 06/11/2013 07:37 AM, Henning Rogge wrote:
>>> On 06/10/2013 09:37 PM, Matteo Danieletto wrote:
>>>> No, I want say it works with ethernet, instead this if(((ifs.int_flags
>>>> & IFF_U) == 0) || ((ifs.int_flags & IFF_RUNNING)==0))
>>>> is always true with WiFi interface.
>>>> I tried several WiFi drivers and Kernel and always there was Interface
>>>> error.
>> I have still no clue what is going on, but something is happening here...
>> A coworker of mine has the same problem.
>> But when he restarted the network (/etc/init.d/networking restart) and
>> brought the interface up again (ifup), the IFF_RUNNING flag was there.
>> @Matteo Danieletto:
>> What distribution and kernel release do you use?
> We tried to look more into this and it seems the problem went away on
> one machine when we deinstalled the Network Manager.
> @Matteo: can you maybe see if this could also be the source of your
> problem?

If that is the case then IMHO olsrd does it wrong.
I googled a bit around and found


which says

>     This flag is read-only for the driver. The kernel turns it on when the interface is active and ready to transfer packets.

>     This flag indicates that the interface is up and running. It is mostly present for BSD compatibility; the kernel makes little use of it. Most network drivers need not worry about IFF_RUNNING.

So IMHO the patch from Matteo is actually right, we should remove the

Ferry Huberts

More information about the Olsr-dev mailing list