[Olsr-dev] olsrd-0.6.4 host emulation mode socket error

Vigneswaran R (spam-protected)
Tue Feb 12 09:31:39 CET 2013

On Tuesday 12 February 2013 12:49 PM, Henning Rogge wrote:
> On 02/11/2013 09:14 AM, Vigneswaran R wrote:
>> Hello,
>> [resending as plain text]
>> When I ran olsrd (0.6.4) in host emulation mode with olsr_switch, I got
>> the error "sendto(v4): Socket operation on non-socket".
>> To reproduce the error, (after doing 'make' and 'make switch')
>>      ./olsr_switch
>>      ./olsrd -f olsrd.emu.conf -hemu
>> To debug, I ran olsrd with 'strace' and found that socket information
>> (the variable 'send_socket') provided to sendto was '0' which caused the
>> above error. On exploring the code, realized that in host emulation mode
>> the 'send_socket' was not set.
>> Following is a small patch to resolve this problem. Thank you.
> Does the "olsr_switch" work for you in experiments after this patch? I 
> would like to hear your opinion, because you might be the first person 
> in years using this code again.

Yes, after this patch I am able to use olsr_switch.

Basically, I am using olsr_switch to simulate lossy links to experiment 
how the LinkQuality (etx_ff) helps in route calculation.


More information about the Olsr-dev mailing list