[Olsr-dev] olsrd-0.6.4 host emulation mode socket error

Henning Rogge (spam-protected)
Tue Feb 12 08:19:40 CET 2013

On 02/11/2013 09:14 AM, Vigneswaran R wrote:
> Hello,
> [resending as plain text]
> When I ran olsrd (0.6.4) in host emulation mode with olsr_switch, I got
> the error "sendto(v4): Socket operation on non-socket".
> To reproduce the error, (after doing 'make' and 'make switch')
>      ./olsr_switch
>      ./olsrd -f olsrd.emu.conf -hemu
> To debug, I ran olsrd with 'strace' and found that socket information
> (the variable 'send_socket') provided to sendto was '0' which caused the
> above error. On exploring the code, realized that in host emulation mode
> the 'send_socket' was not set.
> Following is a small patch to resolve this problem. Thank you.

Does the "olsr_switch" work for you in experiments after this patch? I 
would like to hear your opinion, because you might be the first person 
in years using this code again.

Henning Rogge

Diplom-Informatiker Henning Rogge , Fraunhofer-Institut für
Kommunikation, Informationsverarbeitung und Ergonomie FKIE
Kommunikationssysteme (KOM)
Fraunhofer Straße 20, 53343 Wachtberg, Germany
Telefon +49 228 9435-961,   Fax +49 228 9435 685
mailto:(spam-protected) http://www.fkie.fraunhofer.de

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 6169 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://lists.olsr.org/pipermail/olsr-dev/attachments/20130212/584eaa06/attachment.bin>

More information about the Olsr-dev mailing list