[Olsr-dev] Planned efforts on plugins

Teco Boot (spam-protected)
Fri Feb 5 11:08:10 CET 2010


I've allocated few resources on improvement of plugins.
Priority is dyn_gw, then mdns and then bmf.

1: dyn_gw:
==========
Eliminate the set-up of the thread, in case there is no ping
parameter. This will remove a need of dyn_gw_plain,
as dyn_gw without parameters works exactly as dyn_gw_plain.
Maybe there is a concern on compiling dyn_gw for targets
that don't support threads.


2: mdns:
========
The code can be cleaned up. And I'll validate the (c) issue with
Thales. Don't expect problems, but why not keep them onboard?
It just need one line of comment.
Then, the plugin is to be enhanced for other p2p mechanism, like
MS Groove. My proposal is to include a destination address and port
number parameter. I think we only need UDP.
Because this plugin will support more than mdns, rename it to for
example p2pd (peer to peer discovery)?

LoadPlugin "olsrd_p2pd.so.1.0.0"
{
PlParam     "NonOlsrIf"  "eth0"
PlParam     "NonOlsrIf"  "eth1"
PlParam     "P2pdTtl"  "5"
# Multicast DNS
PlParam     "UdpDestPort"  "224.0.0.251 5353"
# MS Groove
PlParam     "UdpDestPort"  "255.255.255.255 1211"
}

MS Groove can be commented in the default conf.


3: bmf
======
1.6.2 solved my problem. 
Removing the thread is very low on my priority list, or
harmful (I have to verify). Same for the 1.5.3 problem.
The problem with 1.6 is the mutex. Maybe supply the mutex code
on the main olsrd src as patch, and use the mutex conditionally?

Is it really a bad idea to apply the mutex path?


Regards, Teco.





More information about the Olsr-dev mailing list