[Olsr-dev] 0.5.6-rc5 is out

John Hay (spam-protected)
Sun Jun 15 21:59:43 CEST 2008

Hi Hannes,

On Sun, Jun 15, 2008 at 09:02:43PM +0200, Hannes Gredler wrote:
> John Hay wrote:
> >Ok, I have not found the bug yet, but here are 2 patches to help the
> >debugging a bit. The first is to make "HNA Network" timer message
> >work and the second is to fix the printf in prefix_to_netmask().
> tx, have added it to the dev repository.
> >If anyone is interrested, I have left the output of olsrd -nofork -d 3
> >at: ftp://ftp2.za.freebsd.org/pub/local/screenlog.0.bz2
> >
> >It lost a few HNA entries, but not all yet. One to look for is:
> >2001:4200:7000:4
> thats interesting data, and i think i know what the bug is:
> we only insert the candidate route into the RIB on initial,
> reception of a HNA network. now if the TC entry vanishes for some
> reason (e.g. timeout) the candidate route is gone, while the
> HNA entry is still alive which is not quite right.
> so a properly refreshed HNA network never makes its way into
> the routing table.
> i have put in a little bugfix into the dev-repo which always
> attempts to insert candidate routes when a HNA route is received.
> http://gredler.at/hg/olsrd/rev/498a02ffe960

I have tried that, but now olsr get stuck after a little while. I
have tried with -d 0, -d 1 and -d 3. I have put a new file at:


It still reacts to ^C and pressing <enter> does go to a new line.
It just seem to stop sending and processing data. I cannot connect
to port 2004 (dot_draw plugin) either. Never seen this before. I
have run the previous code for long times and it has not happened.
It does not seem to stop at the same place either.

John Hay -- (spam-protected) / (spam-protected)

More information about the Olsr-dev mailing list