[Olsr-users] Netjson bug

Gabriel (spam-protected)
Wed May 17 10:14:35 CEST 2017


Some weird stuff happens in the netjson:
Here you can see the network graphically
http://ninux-graph.netjson.org/topology/53b35ab9-aa6d-4705-89c3-310eac09b0da/
here's the netjson
http://ninux-graph.netjson.org/api/topology/53b35ab9-aa6d-4705-89c3-310eac09b0da/

The attached addresses of the node "id_172.19.185.11" are wrong:
id_172.19.185.11_172.19.64.1 and id_172.19.185.11_172.19.64.2 are 
actually belonging to it's neighbour "id_10.150.9.1".

This is the olsrd2 configuration of 10.150.9.1
config olsrv2 'olsrv2'
	list lan '10.150.9.0/24'

config log 'log'
	option file '/var/log/olsrd2.log'

config global 'global'
	option lockfile '/var/lock/olsrd2'
	option pidfile '/var/run/olsrd2.pid'

config interface 'olsr2_common'
	list ifname 'Ant2'
	list ifname 'Ant1'
	list ifname 'Ant3'
	list ifname 'loopback'
	list ifname 'Ant4'

config telnet 'telnet'
	option port '2009'


#cat /etc/config/network:

config globals 'globals'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '10.150.9.1'
	option _orig_ifname 'eth0.9 wlan0'
	option _orig_bridge 'true'
	option ip6addr 'FDC0:FFEE:0:9609::100/64'
	option ifname 'eth0 eth0.9 eth1'
	option dns '8.8.8.8'

config interface 'Ant1'
	option netmask '255.255.0.0'
	list ipaddr '172.19.64.1'
	option proto 'static'
	option ifname 'eth0.2'

config interface 'Ant2'
	option netmask '255.255.0.0'
	list ipaddr '172.19.64.2'
	option proto 'static'
	option ifname 'eth0.3'

config route 'cfg11c8b4'
	option gateway '10.150.9.1'
	option netmask '255.240.0.0'
	option target '172.16.0.0'
	option interface 'lan'

config route 'cfg0fc8b4'
	option gateway '10.150.9.1'
	option netmask '255.0.0.0'
	option target '10.0.0.0'
	option interface 'lan'

config interface 'Ant3'
	option proto 'static'
	option ifname 'eth0.4'

config interface 'Ant4'
	option proto 'static'
	option ifname 'eth0.5'

config interface 'lo'
	option ipaddr '10.150.9.1'
	option proto 'static'
	option netmask '255.255.255.255'
	option ifname 'lo'

config switch 'cfg053777'
	option name 'switch0'
	option enable_vlan '1'
	option reset '1'

config interface 'loopback'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	option ip6addr 'fdc0:ffee:0:9609::1/128'
	option ifname 'lo'
	option proto 'static'

This is the configuration of 172.19.185.11

#cat /etc/config/olsrd2
config olsrv2 'cfg04fced'
	option originator 'default_accept'

config telnet 'cfg0832f1'
	option port '2009'

config log 'cfg068d07'
	option warning 'all'
	option file '/var/log/olsrd2.log'

config global 'cfg023fd6'
	option failfast 'no'
	option lockfile '/var/lock/olsrd2'
	option pidfile '/var/run/olsrd2.pid'

config olsrv2 'olsrv2'
	list lan '10.150.32.0/24'

config log 'log'
	option file '/var/log/olsrd2.log'

config global 'global'
	option lockfile '/var/lock/olsrd2'
	option pidfile '/var/run/olsrd2.pid'

config interface 'olsr2_common'
	list ifname 'Ant2'
	list ifname 'Ant1'
	list ifname 'Ant3'
	list ifname 'loopback'
	list ifname 'Ant4'

config telnet 'telnet'
	option port '2009'

# cat /etc/config/network
config globals 'globals'

config interface 'lan'
	option force_link '1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '10.150.32.1'
	option delegate '0'
	option type 'bridge'
	option ifname 'eth1.7'
	option dns '208.67.222.222 208.67.220.220 8.8.4.4 8.8.8.8'

config interface 'lo'
	option ipaddr '10.150.32.1'
	option netmask '255.255.255.255'
	option ifname 'lo'

config interface 'Ant4'
	option proto 'static'
	option ifname 'eth1.5'

config interface 'Ant2'
	option proto 'static'
	option ifname 'eth1.3'

config interface 'Ant1'
	option proto 'static'
	option ifname 'eth1.2'

config interface 'Ant3'
	option proto 'static'
	option ifname 'eth1.4'

config interface 'loopback'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	option ip6addr 'FDC0:FFEE:0:9620::1/64'
	option ifname 'lo'
	option proto 'static'



Thanks, Gabriel



More information about the Olsr-users mailing list