[Olsr-users] OLSRd2 : some config problems in OpenWRT

(spam-protected) (spam-protected)
Sun May 8 08:45:49 CEST 2016


Hi, all

I am a freshman in OLSR. I have built OpenWRT CC 15.05 with oonf-olsrd2 v0.11.3, but I am in trouble with how to make it work and the mechanism of olsrd2 really confuse me. What use is the loopback interface for in the olsrd2 and which configuration files do users need to set?

I want to build a mesh network with several router nodes. In the troubleshooting test, the neighboring nodes can see each other with "iw wlan0 station dump" command and they can ping each other. But it cannot ping other nodes if they are not neighboring. And I also tried the command like "echo /nhdpinfo link | nc 127.0.0.1 2009" or "echo /olsrv2info originator | nc 127.0.0.1 2009", but it replys nothing. So i doubt if i make the wrong configuration whcih fails the olsrd2. Below contains the configuration files(network,wireless,olsrd2) and ifconfig results. Hope someone could point out the mistake i made or provide me with some complete config files, thx.

***********************************
/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
                                               
config interface 'lan'   #lan is used as access point
        option ifname 'eth0.1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.8'
        option netmask '255.255.255.0'
        option ip6assign '60'  

config interface 'wlan'  #wlan is used as a mesh interface           
        option proto 'static'      
        option ipaddr '10.0.0.8'      
        option netmask '255.255.255.0'
                             
config interface 'wan'
        option ifname 'eth1'
        option proto 'static'   
        option ipaddr '210.45.76.8'
        option netmask '255.255.255.0'                  
                                               
config switch                                  
        option name 'switch0'                  
        option reset '1'                       
        option enable_vlan '1'                 
        option blinkrate '2'                   
                                      
config switch_vlan                    
        option device 'switch0'       
        option vlan '1'               
        option ports '0 1 2 3 5t'     
                                      
config switch_port                    
        option device 'switch0'       
        option port '1'          
        option led '6'           
                           
config switch_port                    
        option device 'switch0'       
        option port '2'               
        option led '9'                
                                 
config switch_port               
        option device 'switch0'  
        option port '5'          
        option led '2'

**************************************
/etc/config/wireless

config wifi-device  radio0
        option type     mac80211
        option channel  11
        option hwmode   11g
        option path     'pci0000:00/0000:00:11.0'
        option htmode   HT20
        # REMOVE THIS LINE TO ENABLE WIFI:
        #option disabled 1

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     OpenWrt_tt8
        option encryption none

config wifi-iface  wmesh
        option device   radio0
        option ifname   adhoc0
        option network  wlan
        option mode     adhoc
        option ssid     mesh_olsrv2
        option bssid    be:ca:ff:ee:ba:be

config wifi-device  radio1
        option type     mac80211
        option channel  36
        option hwmode   11a
        option path     'pci0000:00/0000:00:12.0'
        option htmode   HT20
        # REMOVE THIS LINE TO ENABLE WIFI:
        option disabled 1

**************************************
/etc/config/olsrd2

config global
        option 'failfast'       'no'
        option 'pidfile'        '/var/run/olsrd2.pid'
        option 'lockfile'       '/var/lock/olsrd2'

config log
        option 'syslog'         'true'
        option 'stderr'         'true'
        option 'file'           '/var/log/olsrd2.log'
        option 'info'           'all'
        option 'debug'          'all'

config telnet
        option  'port'          '2009'

config olsrv2
        list    'lan'           '::/0'
# list 'lan' '0.0.0.0/0'

config interface
        option 'ifname'         'loopback'
#       option 'lan'            '10.0.2.1/24'

config interface
        list    'ifname'        'adhoc0'

#config interface
#        list    'ifname'        'wan'
#        option 'ignore'         '1'
#       option 'rx_bitrate' '100M'
#       option 'tx_bitrate' '100M'
#       option 'signal' '-20'

#config interface
#        list    'ifname'        'lan'
#        option  'ignore'        '1'
#       option 'rx_bitrate' '1G'
#       option 'tx_bitrate' '1G'
#       option 'signal' '-10'

*******************************************
ifconfig

adhoc0    Link encap:Ethernet  HWaddr 2C:B0:5D:9C:44:ED  
          inet addr:10.0.0.8  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: fe80::2eb0:5dff:fe9c:44ed/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:20827 errors:0 dropped:0 overruns:0 frame:0
          TX packets:42277 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:7136952 (6.8 MiB)  TX bytes:17852188 (17.0 MiB)

br-lan    Link encap:Ethernet  HWaddr 2E:B0:5D:9C:44:ED  
          inet addr:192.168.1.8  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::2cb0:5dff:fe9c:44ed/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:731 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:334 (334.0 B)  TX bytes:64066 (62.5 KiB)

eth0      Link encap:Ethernet  HWaddr 2E:B0:5D:9C:44:ED  
          inet6 addr: fe80::2cb0:5dff:fe9c:44ed/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:317 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:25321 (24.7 KiB)
          Interrupt:4

eth0.1    Link encap:Ethernet  HWaddr 2E:B0:5D:9C:44:ED  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:309 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:22224 (21.7 KiB)

eth1      Link encap:Ethernet  HWaddr 2C:B0:5D:9C:44:EE  
          inet addr:210.45.76.8  Bcast:210.45.76.255  Mask:255.255.255.0
          inet6 addr: fe80::2eb0:5dff:fe9c:44ee/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:54059 errors:0 dropped:911 overruns:0 frame:0
          TX packets:34922 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:6362918 (6.0 MiB)  TX bytes:9350810 (8.9 MiB)
          Interrupt:5

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:25752 errors:0 dropped:0 overruns:0 frame:0
          TX packets:25752 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1778793 (1.6 MiB)  TX bytes:1778793 (1.6 MiB)

wlan0-1   Link encap:Ethernet  HWaddr 2E:B0:5D:9C:44:ED  
          inet6 addr: fe80::2cb0:5dff:fe9c:44ed/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1 errors:0 dropped:0 overruns:0 frame:0
          TX packets:313 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:342 (342.0 B)  TX bytes:28284 (27.6 KiB)

*************************************

I also wonder that if i need to modify the olsrd2 file in /etc/init.d/ which has content as follows:

#!/bin/sh /etc/rc.common

START=82
DAEMON='olsrd2'

. /lib/functions/oonf_init.sh

And I think it will help many people like me if there is some pages designed to tell how to config olsrv2 in OpenWRT in the wiki.


Thanks for any help.
Greetings,
Chaojie Yu
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.olsr.org/pipermail/olsr-users/attachments/20160508/fd2dcbd6/attachment-0001.html>


More information about the Olsr-users mailing list