[Olsr-users] [OLSRD] adhoc network

Hans-Christoph Steiner (spam-protected)
Wed Feb 20 23:55:16 CET 2013

Very few Android 4.x support Adhoc out-of-box.  You can use a custom kernel,
or it might be possible with just a custom wpa_supplicant.

You might also be interested in the olsrd app for Android:

It won't help you with the low-level issues you're talking about, but it'll
manage connecting once you get adhoc working.  For info on custom kernels and
such, check out the SPAN project:



On 02/20/2013 05:47 PM, Matteo wrote:
> Hi everybody,
> I have a samsung galaxy tab 2 10.1 p5113.
> I downloaded OLSR on Android and I pushed all file inside the tablet.
> Now, I have a problem with wpa_supplicant and wpa_cli. 
> I tried this command line: 
> su -c "/system/bin/wpa_cli -p /data/misc/wifi/"
> But I had this error:
> Selected interface 'sockets'
> Interactive mode
> Could not connect to wpa_supplicant: sockets - re-trying
> Instead with only wpa_cli I can enter and I did scan_results and so on.
> However I can't see the Adhoc network, do I have to change the wpa_supplicant? I tried to change with an wpa_supplicant found with Google but after that the wifi didn't work.
> Do you have any suggestions?
> Thanks a lot
> Matteo

More information about the Olsr-users mailing list