[Olsr-users] Building for Nexus One on Android 2.1

Donadio, Tony (spam-protected)
Thu Mar 25 20:21:42 CET 2010

Has anyone tried building OLSRD recently for the Android platform? I tried downloading and setting up to build 0.5.5-r8 (for the Nexus One) under Ubuntu with the android-ndk-r3 (the current download). When I run the build (make OS=android build_all) I get a lot of errors of the following form resulting from header files not being found:

In file included from src/fpm.c:42:
/home/tdonadio/android-ndk-r3/build/prebuilt/linux-x86/arm-eabi-4.4.0/bin/../lib/gcc/arm-eabi/4.4.0/include-fixed/stdio.h:50:23: error: sys/cdefs.h: No such file or directory
/home/tdonadio/android-ndk-r3/build/prebuilt/linux-x86/arm-eabi-4.4.0/bin/../lib/gcc/arm-eabi/4.4.0/include-fixed/stdio.h:51:24: error: sys/_types.h: No such file or directory
src/fpm.c:43:20: error: assert.h: No such file or directory

>From looking around in the ndk I can find the missing headers under /build/platforms/android-5/arch-arm/usr/include/sys/, but not where the error messages above are complaining about not finding them. I did change Makefile.android to point the NDK variables toward the current ndk directories, but this doesn't seem to help. Can anyone suggest what I may be missing?

Thanks in advance for any help --

Tony Donadio

More information about the Olsr-users mailing list