[Olsr-users] OLSR GUI is corrupting my IP settings ?

Bhat, Ishwara (spam-protected)
Tue Nov 18 13:31:01 CET 2008



I will see if I can debug it and pass on any findings. If possible even
a patch.






From: L. Aaron Kaplan [mailto:(spam-protected)] 
Sent: Monday, November 17, 2008 5:14 PM
To: Bhat, Ishwara
Cc: (spam-protected); Alina Friedrichsen
Subject: Re: [Olsr-users] OLSR GUI is corrupting my IP settings ?



On Nov 14, 2008, at 2:14 PM, Bhat, Ishwara wrote:



I am trying OLSR on Dell 630 laptop and downloaded Broadcom linux driver
for the same. I am running Fedora core 9.


I have an ad hoc network of 2 laptops, one with windows and the second
with Linux. When I begin, I am able to ping the windows laptop from
Linux. Once I run OLSRd, even then it works. 


But now I start running GUI (built from  olsrd/gui/linux-gtk ).  Now if
I ping windows laptop it says host unreachable. 


olsrd/gui/linux-gtk does not (yet) understand the LQ extensions AFAIK.

After 1 hour when I tried, it started pining normally.


OLSRd GUI seems to corrupt something ?  


thanks for the report. 

As said, since that was not used to my knowledge in the
funkfeuer/freifunk networks where most current developers are situated,
probably not so much attention was given to 

the secure plugin as well as the linux-gtk GUI. The linux GTK GUI is
missing the LQ parsing code.


We usually take different packages for visualizing the network:
dot_draw, http_info or txtinfo plugin. These are usually more practical
although for sure not yet perfect.


HOWTO: http://www.olsr.org/?q=node/26



I hope the explanation helped.


Patches are of course - as always welcome


(BTW: mille gracias Alina!! - just reading thru the v6 patch now... (and
bernd was faster ) :))) 





-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.olsr.org/pipermail/olsr-users/attachments/20081118/93863a9a/attachment.html>

More information about the Olsr-users mailing list