[OLSR-users] CVS ipkg updated (minus dyn_gw)

Andreas T√łnnesen (spam-protected)
Fri Feb 25 22:33:01 CET 2005


John,

Cool :)
Regarding the segfault it's not reproduceable on the x86 version.
You are 100% sure you cleaned all object files before compiling?
the dependency checking in plugin makefiles is pretty much none-existent
and there has been a lot of changes, mostly restructuring, in plugin
code recently.
If you did a clean build we should try to trace the segfault. Is there
any debuggin tools available for the WRT system(gdb or stuff like
strace)?

- Andreas


John Gorkos wrote:
> OLSR'ers -
> 
>   Just put another MIPS (wrt54g) ipkg up on my package server of today's 
> snapshot, for those of you that like to live on the bleeding edge.
> http://www.wildcatwireless.net/wrt54g/olsrd_0.4.9-cvs-wrt2_mipsel.ipk
> 
> 
> Andreas:  I'm getting this when I try to load the dyn_gw:
> 
> ---------- Plugin loader ----------
> Library: olsrd_dyn_gw.so.0.3
> Segmentation fault
> 
> This is both stripped and unstripped.  Let me know if I need to dig deeper.  I 
> know, this is the price for living on the bleeding edge.  It's not going into 
> production today (not until Monday, anyway... :)
> 
> John Gorkos
> _______________________________________________
> olsr-users mailing list
> (spam-protected)
> https://www.olsr.org/mailman/listinfo/olsr-users

-- 
Andreas T√łnnesen
http://www.olsr.org



More information about the Olsr-users mailing list