[OLSR-users] Mesh not meshing

Andreas T√łnnesen (spam-protected)
Tue Sep 14 08:01:58 CEST 2004


Hi Marc,

I belive the problem was solved quite some time ago, it was a firewall
issue. But anyways - the MBK project is interesting :-)

- Andreas


On Mon, 13 Sep 2004, Marc Quinton wrote:

> John Gorkos wrote:
> 
> >Ok, we're closer.  I've now added a fourth node to the mesh.  It's 
> >located in a masked area that can only see 1 other node.  The new node 
> >is .7.22,  and it can only see .7.25.  OLSR is working in the sense 
> >that I get this routing table:
> >Kernel IP routing table
> >Destination     Gateway         Genmask         Flags Metric Ref    
> >Use Iface
> >192.168.7.1     192.168.7.25    255.255.255.255 UGH   2      0        
> >0 eth1
> >192.168.7.20    192.168.7.25    255.255.255.255 UGH   3      0        
> >0 eth1
> >192.168.7.21    192.168.7.25    255.255.255.255 UGH   3      0        
> >0 eth1
> >192.168.7.25    *               255.255.255.255 UH    1      0        
> >0 eth1
> >192.168.7.0     *               255.255.255.0   U     0      0        
> >0 eth1
> >192.168.1.0     *               255.255.255.0   U     0      0        
> >0 vlan1
> >192.168.99.0    *               255.255.255.0   U     0      0        
> >0 vlan0
> >default         192.168.7.25    0.0.0.0         UG    2      0        
> >0 eth1
> >
> >Which is correct.  However, I cannot ping or pass traffic to anything 
> >other than the .7.25 node.  I cannot ping .7.1 (which is two hops 
> >away) or .7.20 or .7.21, which are three hops away.  I hope I'm 
> >counting hops right.  Anyway, is there a setting I'm missing somewhere 
> >on my .7.25 router that would prevent it from forwarding on the 
> >packets from .7.22 to the rest of the mesh?
> > These are all new problems to me, since all of my meshes were too 
> >small to have hidden nodes before.  Thoughts? 
> 
> 
> I am using Unik-OLSR with Openwrt. I have multiple nodes with sometime
> some hops. I have no problems at all except wireless propagation.
> 
> You could have a look at our firmware now named MBK. It's based on Openwrt
> with a integrated micro web server. It's nearly complet with an easy 
> user interface.
> Just need to fill some values and push apply and reboot.
> 
> You'll find it at : http://wrt54g.free.fr/
> 
> I've stoped working on it for now because of my private life ... But I'm 
> still here.
> 
> For your problem, you should
> - make some testing point to point,
> - desactivate firewall rules if no thing seems to work,
> - work with IP not dns host names,
> - make AP do IP forwarding,
> 
> and it should work.
> 
> 
> 
> _______________________________________________
> olsr-users mailing list
> (spam-protected)
> https://www.olsr.org/mailman/listinfo/olsr-users

-- 
Andreas T√łnnesen((spam-protected))
http://www.olsr.org



More information about the Olsr-users mailing list