[OLSR-users] Mips-Processor: Plugins will SEGV

Bruno Randolf (spam-protected)
Mon Nov 1 13:12:43 CET 2004


On Monday 01 November 2004 11:51, Andreas T√łnnesen wrote:

> This issue has been discussed before:
> http://www.olsr.org/pipermail/olsr-users/2004-October/000233.html
> But I don't think any conclusions were drawn there... But you could check
> out the mips-i vs. mips-ii issue mentioned there.

i have just tried it with both mips-1 and mips-2

> I guess it could be something uclibc related. 

no, i dont think so. it happens also on a glibc system (the meshcube).

i just tried to debug the problem with gdb:

Program received signal SIGSEGV, Segmentation fault.
0x2ae687a8 in register_olsr_data (data=0x7fff6c70) at src/olsrd_plugin.c:116
warning: Source file is more recent than executable.

116       olsr_plugin_io = data->olsr_plugin_io;
(gdb) print olsr_plugin_io
$1 = (int (*)(int, void *, size_t)) 0
(gdb) print data->olsr_plugin_io
$2 = (int (*)(int, void *, size_t)) 0x41b670 <olsr_plugin_io>
(gdb) print sizeof(olsr_plugin_io)
$3 = 1
(gdb) print sizeof(data->olsr_plugin_io)
$4 = 4

not sure if this is it, but it looks like olsr_plugin_io is not the same size 
as data->olsr_plugin_io, but maybe i misunderstood something???

bruno
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://lists.olsr.org/pipermail/olsr-users/attachments/20041101/f269b6e9/attachment.sig>


More information about the Olsr-users mailing list