[Olsr-dev] [Olsr-users] [SUGGESTION] Interface no up and/or running

Henning Rogge (spam-protected)
Fri Jun 14 11:31:12 CEST 2013

On 06/11/2013 07:37 AM, Henning Rogge wrote:
> On 06/10/2013 09:37 PM, Matteo Danieletto wrote:
>> No, I want say it works with ethernet, instead this if(((ifs.int_flags
>> & IFF_U) == 0) || ((ifs.int_flags & IFF_RUNNING)==0))
>> is always true with WiFi interface.
>> I tried several WiFi drivers and Kernel and always there was Interface
>> error.

I have still no clue what is going on, but something is happening here...

A coworker of mine has the same problem.

But when he restarted the network (/etc/init.d/networking restart) and 
brought the interface up again (ifup), the IFF_RUNNING flag was there.

@Matteo Danieletto:
What distribution and kernel release do you use?

Henning Rogge

Diplom-Informatiker Henning Rogge , Fraunhofer-Institut für
Kommunikation, Informationsverarbeitung und Ergonomie FKIE
Kommunikationssysteme (KOM)
Fraunhofer Straße 20, 53343 Wachtberg, Germany
Telefon +49 228 9435-961,   Fax +49 228 9435 685
mailto:(spam-protected) http://www.fkie.fraunhofer.de

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 6169 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://lists.olsr.org/pipermail/olsr-dev/attachments/20130614/30f6e847/attachment.bin>

More information about the Olsr-dev mailing list