[Olsr-dev] olsrd-0.6.4 host emulation mode socket error

Vigneswaran R (spam-protected)
Mon Feb 11 08:58:34 CET 2013


When I ran olsrd (0.6.4) in host emulation mode with olsr_switch, I got 
the error "sendto(v4): Socket operation on non-socket".

To reproduce the error, (after doing 'make' and 'make switch')

./olsrd -f olsrd.emu.conf -hemu

To debug, I ran olsrd with 'strace' and found that socket information 
(the variable 'send_socket') provided to sendto was '0' which caused the 
above error. On exploring the code, realized that in host emulation mode 
the 'send_socket' was not set.

PFA, a small patch to resolve this problem. Thank you.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.olsr.org/pipermail/olsr-dev/attachments/20130211/740275ab/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: olsrd_0.6.4_hemu_sock_err.patch
Type: text/x-patch
Size: 520 bytes
Desc: not available
URL: <http://lists.olsr.org/pipermail/olsr-dev/attachments/20130211/740275ab/attachment.bin>

More information about the Olsr-dev mailing list