[Olsr-dev] olsrd debian update

Hans-Christoph Steiner (spam-protected)
Thu Jun 7 00:45:28 CEST 2012

On 06/06/2012 06:25 PM, Ferry Huberts wrote:
> On 07-06-12 00:04, Hans-Christoph Steiner wrote:
>> Can you tell me what didn't get installed properly?   Try this, then you
>> can see the results in /tmp/olsrd:
> I need to think a bit about USRDIR, but for sure SHAREDIR and DOCDIR
> must be overridden
> my 'install' is not correct with your patch because I use USRDIR and
> SHAREDIR (this is in my local branch)
> I look some more into it tomorrow

Ah, I see, sorry, I tested using 'make libs_install' and 'make install'
but didn't test things not in those two.  I tried 'make
sgwdynspeed_install' and that worked fine. It seems that only libnmea
and libOlsrdPudWireFormat are ending up in the wrong place:



That seems to be because 'usr/lib' is hardcoded in
lib/pud/wireformat/Makefile.  If that Makefile is changed to use the
olsrd/Makefile variables instead of LIBDIR_INSTALL, it'll work.


More information about the Olsr-dev mailing list