[Olsr-dev] 0.5.6-rc5 is out

John Hay (spam-protected)
Mon Jun 16 09:53:38 CEST 2008

On Mon, Jun 16, 2008 at 08:57:18AM +0200, Hannes Gredler wrote:
> >>i have put in a little bugfix into the dev-repo which always
> >>attempts to insert candidate routes when a HNA route is received.
> >>
> >>http://gredler.at/hg/olsrd/rev/498a02ffe960
> >
> >I have tried that, but now olsr get stuck after a little while. I
> >have tried with -d 0, -d 1 and -d 3. I have put a new file at:
> >
> >ftp://ftp2.za.freebsd.org/pub/local/screenlog.1.bz2
> >
> >It still reacts to ^C and pressing <enter> does go to a new line.
> >It just seem to stop sending and processing data. I cannot connect
> >to port 2004 (dot_draw plugin) either. Never seen this before. I
> >have run the previous code for long times and it has not happened.
> >It does not seem to stop at the same place either.
> can you pull a coredump while its in stuck state (gcore -s)
> and post it along with your olsrd binary, then i'll try to figure
> where it hangs.

Ahh, you learn something new every day. I did not know about gcore.
I tried various kill signals, but could not get a coredump out of
the thing. :-) Gcore posed a few more requirements, like procfs and
pseudofs, which I did not have on that box. :-)

Ok, there is an olsrd and core.37982 in

I hope you can make sense out of it. :-)

John Hay -- (spam-protected) / (spam-protected)

More information about the Olsr-dev mailing list