[Olsr-dev] forwarding is not set after on olsrd restart

Markus Kittenberger (spam-protected)
Sat Aug 2 11:51:57 CEST 2008

What i found is (it`s really not a bug (-; just a not so nice usage

At the start of olsr /proc/sys/net/ipv4/ip_forward normally gets set to 1
(if it`s not already set to 1)

and if it wasn`t its set back to 0 when the daemon stopps,..

but i ran into problems with an init.d script which performs an olsr restart
like this:

killall olsrd
olsrd -f /etc/olsrd.conf -d 0

maybe it`s not the best idea to do it this way, but i asume many peole do it
so, or similar (eg. using pid-file ),..

of course killall -w would also solve following problem

after an restart forwarding isn`t set to 1 anymore (on a multicore (virtual)
server the chance to get this was > 90%, on an other server (single core) it
occured only ocassionally)

i solved this issue by enabling forwarding on this systems by default,..
but maybe an starting olsr schould set forwarding a bit delayed/later, so
that an stopping olsrd is not reseting forwarding to 0 AFTER the starting
one has set it to 1

or the stoppping olsr shoudl only reset it when he finds no other olsrds
running on the system,..

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.olsr.org/pipermail/olsr-dev/attachments/20080802/d167b94c/attachment.html>

More information about the Olsr-dev mailing list