[olsr-dev] 0.4.9 CVS hangs while deleting route

Andreas T√łnnesen (spam-protected)
Sat Feb 26 12:53:51 CET 2005


Thanks for reporting in Sven! Seems like there is a problem with
the route calculation - multiple routes to the same host is added.
We'll look into it.

- Andreas

Sven-Ola Tuecke wrote:
> Hi,
> 
> with the current CVS version of olsrd, the daemon hangs in an endless loop 
> while deleting routes. I dont know, if it is possible to reproduce the 
> results, so I try to fetch some infos before I restart all daemons in order 
> to write this mail.
> 
> I attach a complete log made with -d 9 -dispin -dispout and a gdb backtrace as 
> well. Hope it helps. The config where this hang is encounter described in 
> short:
> 
> - My notebook 104.65.65.68, actual cvs-0.4.9, single wlan in ad-hoc
> - wrt54g with olsrd-cvs-0.4.9 (week old) single wlan 104.65.65.66/8
> - wrt54g with olsrd-cvs-0.4.9 (week old) single wlan 104.65.65.67/8
> - wrt54gs with olsrd-cvs-0.4.9 (week old) wlan 104.65.65.97/8 and a second 
> ether iface vlan1=104.65.65.111/26.  There was no other olsrd at the other 
> end of the ethernet wire - I have stopped the other device to cut olsr 
> broadcasts from the berlin mesh in order to have a small routing table
> - therefore no hna4 for defaultgw in range
> 
> all three wrts have dyngw, httpinfo and nameinfo plugin, but that should not 
> interfere here...
> 
> Regards, Sven-Ola
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> olsr-dev mailing list
> (spam-protected)
> https://www.olsr.org/mailman/listinfo/olsr-dev

-- 
Andreas T√łnnesen
http://www.olsr.org



More information about the Olsr-dev mailing list