[Olsr-cvs] olsrd-current/lib/bmf/src Bmf.c, 1.10, 1.11 NetworkInterfaces.c, 1.12, 1.13
Bernd Petrovitsch
(spam-protected)
Thu Nov 29 01:49:42 CET 2007
Update of /cvsroot/olsrd/olsrd-current/lib/bmf/src
In directory sc8-pr-cvs3.sourceforge.net:/tmp/cvs-serv16024/lib/bmf/src
Modified Files:
Bmf.c NetworkInterfaces.c
Log Message:
Major Changes:
- renamed "struct local_hna_entry" to "struct ip_prefix_list" since
it is exactly that. Renamed the functions in src/local_hna_set.{c,h}
in the same way.
- each IPv4 and IPv6 function pairs in src/local_hna_set.{c,h} is
called from the same place and have the same signature. So I
condensed each of them.
- Since we have only 3 functions left in src/local_hna_set.{c,h}
and they are used for the configuration, the .h file is now part
of src/olsr_cfg.h and the ,c file of src/cfgparser/olsrd_conf.c.
- replaced "struct ipc_net" with "struct ip_prefix_list" since it
serves the same purpose as the "struct ip_prefix_list"
- replaced "struct ipc_host" with "struct ip_prefix_list" since it
serves the same purpose as the "struct ip_prefix_list" and is
just a special case. No need to duplicate code etc.
- removed "union hna_netmask" from src/olsr_types since we use the
prefix_len everywhere (and that is an olsr_u8_t in several other
struct's).
That implies changes and simplifications in the code handling
them (since the IPv4 is similar to IPv6).
- the config file parser now understands for IPv4 addresses also
"/$prefix".
- On the output side, the patch generates only "/$prefix" which
kills code since it is the same as the IPv6 handling.
- There are some netmask conversions left (mainly in the plugins)
but that be cleaned up afterwards.
- extracted ip{,4,6}{cmp,equal} and formatting functions from
net_olsr.{c,h} into src/ipcalc.{c,h} since net_olsr.h became
IMHO to much of a "put anything in there".
- renamed "sockaddr_to_string()" to "sockaddr4_to_string()"
since it is exactly that (unless I'm missing something).
Minor Changes:
- lib/httpinfo/src/admin_html.h contained just some variable
definitions so it is now integrated in the only user:
admin_interface.c
- olsrd_dot_draw.c got rid of two indicator variables if
a socket is valid or not. Since sockets may use "-1" as the
"not open", "invalid" value, there is no need for two more
ints.
- and the dot_draw plugin is somewhat smaller and easier to read.
- const'ified some functions
Index: NetworkInterfaces.c
===================================================================
RCS file: /cvsroot/olsrd/olsrd-current/lib/bmf/src/NetworkInterfaces.c,v
retrieving revision 1.12
retrieving revision 1.13
diff -C2 -d -r1.12 -r1.13
*** NetworkInterfaces.c 16 Nov 2007 19:12:55 -0000 1.12
--- NetworkInterfaces.c 29 Nov 2007 00:49:40 -0000 1.13
***************
*** 59,64 ****
/* OLSRD includes */
#include "olsr.h" /* olsr_printf() */
#include "defs.h" /* olsr_cnf */
- #include "local_hna_set.h" /* add_local_hna4_entry() */
#include "link_set.h" /* get_link_set() */
#include "lq_route.h" /* MIN_LINK_QUALITY */
--- 59,64 ----
/* OLSRD includes */
#include "olsr.h" /* olsr_printf() */
+ #include "ipcalc.h"
#include "defs.h" /* olsr_cnf */
#include "link_set.h" /* get_link_set() */
#include "lq_route.h" /* MIN_LINK_QUALITY */
***************
*** 1356,1364 ****
{
union olsr_ip_addr temp_net;
- union olsr_ip_addr temp_netmask;
temp_net.v4.s_addr = htonl(EtherTunTapIp);
! temp_netmask.v4.s_addr = htonl(0xFFFFFFFF);
! add_local_hna4_entry(&temp_net, &temp_netmask);
}
--- 1356,1362 ----
{
union olsr_ip_addr temp_net;
temp_net.v4.s_addr = htonl(EtherTunTapIp);
! ip_prefix_list_add(&olsr_cnf->hna_entries, &temp_net, 32);
}
Index: Bmf.c
===================================================================
RCS file: /cvsroot/olsrd/olsrd-current/lib/bmf/src/Bmf.c,v
retrieving revision 1.10
retrieving revision 1.11
diff -C2 -d -r1.10 -r1.11
*** Bmf.c 16 Nov 2007 19:12:55 -0000 1.10
--- Bmf.c 29 Nov 2007 00:49:40 -0000 1.11
***************
*** 58,61 ****
--- 58,62 ----
/* OLSRD includes */
#include "defs.h" /* olsr_cnf, OLSR_PRINTF */
+ #include "ipcalc.h"
#include "olsr.h" /* olsr_printf */
#include "scheduler.h" /* olsr_register_scheduler_event */
More information about the Olsr-cvs
mailing list